Skip to content

← Actionable
High, CVSS 8.1

go.etcd.io/etcd Authentication Bypass

CVE-2018-16886GHSA-h6xx-pmxh-3wgp

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (go.etcd.io/etcd/v3 3.3.11, 3.2.26; go.etcd.io/etcd 0.5.0-alpha.5.0.20190108173120-83c051b701d3), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • Go go.etcd.io/etcd/v3

    Affected
    >= 3.2.0, < 3.2.26>= 3.3.0, < 3.3.11
    Fixed in
    3.2.26, 3.3.11
  • Go go.etcd.io/etcd

    Affected
    < 0.5.0-alpha.5.0.20190108173120-83c051b701d3
    Fixed in
    0.5.0-alpha.5.0.20190108173120-83c051b701d3

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
8.1 · CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:H/A:H
EPSS
  • CVE-2018-16886: 4.06% estimated exploitation activity in the next 30 days; percentile 90.68 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

etcd versions 3.2.x before 3.2.26 and 3.3.x before 3.3.11 are vulnerable to an improper authentication issue when role-based access control (RBAC) is used and client-cert-auth is enabled. If an etcd client server TLS certificate contains a Common Name (CN) which matches a valid RBAC username, a remote attacker may authenticate as that user with any valid (trusted) client certificate in a REST API request to the gRPC-gateway.

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 1 · created ·

    Published from ghsa record GHSA-h6xx-pmxh-3wgp

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2018-16886

Advisory: go.etcd.io/etcd Authentication Bypass
IDs: CVE-2018-16886, GHSA-h6xx-pmxh-3wgp
Record: https://patchnext.com/advisories/cve-2018-16886 (revision 1, source checked 26 Oct 2026, 14:58 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: High (CVSS 8.1)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: go.etcd.io/etcd/v3 3.3.11, 3.2.26; go.etcd.io/etcd 0.5.0-alpha.5.0.20190108173120-83c051b701d3. A vendor fix does not mean a deployment is fixed.

## Affected components
- Go go.etcd.io/etcd/v3: affected >= 3.2.0, < 3.2.26; >= 3.3.0, < 3.3.11; fixed in 3.2.26, 3.3.11
- Go go.etcd.io/etcd: affected < 0.5.0-alpha.5.0.20190108173120-83c051b701d3; fixed in 0.5.0-alpha.5.0.20190108173120-83c051b701d3

## Suggested inspection (read-only)
- Go go.etcd.io/etcd/v3: check the installed version with your package manager.
- Go go.etcd.io/etcd: check the installed version with your package manager.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on go.etcd.io/etcd/v3, go.etcd.io/etcd.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-h6xx-pmxh-3wgp (GitHub-reviewed advisory GHSA-h6xx-pmxh-3wgp lists affected ranges: Go go.etcd.io/etcd/v3 >=3.2.0 =3.3.0 =0 <0.5.0-alpha.5.0.20190108173120-83c051b701d3)

Commands are suggestions: review each one before running it.

Loading voting…