Ansible Logs Passwords If PowerShell ScriptBlock is Enabled
CVE-2018-16859GHSA-v735-2pp6-h86r
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (ansible 2.7.3, 2.6.9, 2.5.12), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
PyPI ansible
- Affected
- >= 2.7.0a1, < 2.7.3< 2.5.12>= 2.6.0a1, < 2.6.9
- Fixed in
- 2.6.9, 2.7.3, 2.5.12
Sources
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-v735-2pp6-h86r lists affected ranges: PyPI ansible >=2.7.0a1 =0 =2.6.0a1 <2.6.9 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-v735-2pp6-h86r lists affected ranges: PyPI ansible >=2.7.0a1 =0 =2.6.0a1 <2.6.9
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS 4.0
- 6.7 · CVSS:4.0/AV:L/AC:L/AT:N/PR:H/UI:N/VC:H/VI:N/VA:N/SC:N/SI:N/SA:N · score source
- EPSS
- CVE-2018-16859: 0.54% estimated exploitation activity in the next 30 days; percentile 45.44 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Execution of Ansible playbooks on Windows platforms with PowerShell ScriptBlock logging and Module logging enabled can allow for 'become' passwords to appear in EventLogs in plaintext. A local user with administrator privileges on the machine can view these logs and discover the plaintext password. Ansible Engine 2.8 and older are believed to be vulnerable.
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 3 · amended ·
Amended from ghsa record GHSA-v735-2pp6-h86r
- Revision 2 · amended ·
Reviewed OSV alias/range/CVSS4 correction; package source scopes and original publication preserved. No customer finding resolved.
- Revision 1 · created ·
Published from osv record GHSA-v735-2pp6-h86r
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2018-16859 Advisory: Ansible Logs Passwords If PowerShell ScriptBlock is Enabled IDs: CVE-2018-16859, GHSA-v735-2pp6-h86r Record: https://patchnext.com/advisories/cve-2018-16859 (revision 3, source checked 26 Oct 2026, 13:16 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Medium (CVSS 6.7) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: ansible 2.7.3, 2.6.9, 2.5.12. A vendor fix does not mean a deployment is fixed. ## Affected components - PyPI ansible: affected >= 2.7.0a1, < 2.7.3; < 2.5.12; >= 2.6.0a1, < 2.6.9; fixed in 2.6.9, 2.7.3, 2.5.12 ## Suggested inspection (read-only) - `python -m pip show ansible`: prints the installed version. Run with the environment that serves production active. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on ansible. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://osv.dev/vulnerability/GHSA-v735-2pp6-h86r (OSV record GHSA-v735-2pp6-h86r lists affected ranges: PyPI ansible >=2.7.0a1 =0 =2.6.0a1 <2.6.9 (fixed)) - Verified: https://github.com/advisories/GHSA-v735-2pp6-h86r (GitHub-reviewed advisory GHSA-v735-2pp6-h86r lists affected ranges: PyPI ansible >=2.7.0a1 =0 =2.6.0a1 <2.6.9) Commands are suggestions: review each one before running it.
Loading voting…