Smarty Path Traversal Vulnerability
CVE-2018-16831GHSA-65j5-vpm7-6xp4
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (smarty/smarty 3.1.33), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
Packagist smarty/smarty
- Affected
- < 3.1.33
- Fixed in
- 3.1.33
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-65j5-vpm7-6xp4 lists affected ranges: Packagist smarty/smarty >=0 <3.1.33
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 5.9 · CVSS:3.0/AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:N/A:N
- EPSS
- CVE-2018-16831: 2.66% estimated exploitation activity in the next 30 days; percentile 85.73 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Smarty before 3.1.33-dev-4 allows attackers to bypass the trusteddir protection mechanism via a file:./../ substring in an include statement.
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 1 · created ·
Published from ghsa record GHSA-65j5-vpm7-6xp4
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2018-16831 Advisory: Smarty Path Traversal Vulnerability IDs: CVE-2018-16831, GHSA-65j5-vpm7-6xp4 Record: https://patchnext.com/advisories/cve-2018-16831 (revision 1, source checked 26 Oct 2026, 14:16 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Medium (CVSS 5.9) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: smarty/smarty 3.1.33. A vendor fix does not mean a deployment is fixed. ## Affected components - Packagist smarty/smarty: affected < 3.1.33; fixed in 3.1.33 ## Suggested inspection (read-only) - Packagist smarty/smarty: check the installed version with your package manager. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on smarty/smarty. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-65j5-vpm7-6xp4 (GitHub-reviewed advisory GHSA-65j5-vpm7-6xp4 lists affected ranges: Packagist smarty/smarty >=0 <3.1.33) Commands are suggestions: review each one before running it.
Loading voting…