Prototype Pollution in extend
CVE-2018-16492GHSA-qrmc-fj45-qfc2
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (extend 3.0.2, 2.0.2), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
npm extend
- Affected
- >= 3.0.0, < 3.0.2>= 1.1.3, < 2.0.2
- Fixed in
- 3.0.2, 2.0.2
Sources
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-qrmc-fj45-qfc2 lists affected ranges: npm extend >=3.0.0 =1.1.3 <2.0.2 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-qrmc-fj45-qfc2 lists affected ranges: npm extend >=3.0.0 =1.1.3 <2.0.2
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- not scored
- EPSS
- CVE-2018-16492: 3.05% estimated exploitation activity in the next 30 days; percentile 87.58 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Versions of extend prior to 3.0.2 (for 3.x) and 2.0.2 (for 2.x) are vulnerable to Prototype Pollution. The extend() function allows attackers to modify the prototype of Object causing the addition or modification of an existing property that will exist on all objects. Recommendation If you're using extend 3.x upgrade to 3.0.2 or later. If you're using extend 2.x upgrade to 2.0.2 or later.
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 2 · amended ·
Amended from ghsa record GHSA-qrmc-fj45-qfc2
- Revision 1 · created ·
Published from osv record GHSA-qrmc-fj45-qfc2
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2018-16492 Advisory: Prototype Pollution in extend IDs: CVE-2018-16492, GHSA-qrmc-fj45-qfc2 Record: https://patchnext.com/advisories/cve-2018-16492 (revision 2, source checked 26 Oct 2026, 12:41 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Unrated Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: extend 3.0.2, 2.0.2. A vendor fix does not mean a deployment is fixed. ## Affected components - npm extend: affected >= 3.0.0, < 3.0.2; >= 1.1.3, < 2.0.2; fixed in 3.0.2, 2.0.2 ## Suggested inspection (read-only) - `npm ls extend --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on extend. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://osv.dev/vulnerability/GHSA-qrmc-fj45-qfc2 (OSV record GHSA-qrmc-fj45-qfc2 lists affected ranges: npm extend >=3.0.0 =1.1.3 <2.0.2 (fixed)) - Verified: https://github.com/advisories/GHSA-qrmc-fj45-qfc2 (GitHub-reviewed advisory GHSA-qrmc-fj45-qfc2 lists affected ranges: npm extend >=3.0.0 =1.1.3 <2.0.2) Commands are suggestions: review each one before running it.
Loading voting…