Rack vulnerable to Denial of Service
CVE-2018-16470GHSA-hg78-4f6x-99wq
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (rack 2.0.6), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
RubyGems rack
- Affected
- >= 2.0.4, < 2.0.6
- Fixed in
- 2.0.6
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-hg78-4f6x-99wq lists affected ranges: RubyGems rack >=2.0.4 <2.0.6
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 7.5 · CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H
- EPSS
- CVE-2018-16470: 2.03% estimated exploitation activity in the next 30 days; percentile 81.09 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
There is a possible DoS vulnerability in the multipart parser in Rack before 2.0.6. Specially crafted requests can cause the multipart parser to enter a pathological state, causing the parser to use CPU resources disproportionate to the request size.
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 1 · created ·
Published from ghsa record GHSA-hg78-4f6x-99wq
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2018-16470 Advisory: Rack vulnerable to Denial of Service IDs: CVE-2018-16470, GHSA-hg78-4f6x-99wq Record: https://patchnext.com/advisories/cve-2018-16470 (revision 1, source checked 26 Oct 2026, 15:48 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: High (CVSS 7.5) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: rack 2.0.6. A vendor fix does not mean a deployment is fixed. ## Affected components - RubyGems rack: affected >= 2.0.4, < 2.0.6; fixed in 2.0.6 ## Suggested inspection (read-only) - RubyGems rack: check the installed version with your package manager. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on rack. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-hg78-4f6x-99wq (GitHub-reviewed advisory GHSA-hg78-4f6x-99wq lists affected ranges: RubyGems rack >=2.0.4 <2.0.6) Commands are suggestions: review each one before running it.
Loading voting…