Skip to content

← Actionable
Medium, CVSS 6.1amended

Cross-Site Scripting in exceljs

CVE-2018-16459GHSA-2j2j-8rrv-264g

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (exceljs 1.6.0), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • npm exceljs

    Affected
    < 1.6.0
    Fixed in
    1.6.0

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
6.1 · CVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N
EPSS
  • CVE-2018-16459: 0.76% estimated exploitation activity in the next 30 days; percentile 55.32 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Versions of exceljs before 1.6.0 are vulnerable to cross-site scripting. This vulnerability is due to exceljs not validating data from parsed XLSX file and embedding HTML tags, like <script directly into the sheet cells. Because of this it's possible to inject malicious JavaScript code and execute it when data from the sheet is displayed in the browser. Recommendation Update to version 1.6.0 or later.

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 2 · amended ·

    Amended from ghsa record GHSA-2j2j-8rrv-264g

  2. Revision 1 · created ·

    Published from osv record GHSA-2j2j-8rrv-264g

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2018-16459

Advisory: Cross-Site Scripting in exceljs
IDs: CVE-2018-16459, GHSA-2j2j-8rrv-264g
Record: https://patchnext.com/advisories/cve-2018-16459 (revision 2, source checked 26 Oct 2026, 12:26 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Medium (CVSS 6.1)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: exceljs 1.6.0. A vendor fix does not mean a deployment is fixed.

## Affected components
- npm exceljs: affected < 1.6.0; fixed in 1.6.0

## Suggested inspection (read-only)
- `npm ls exceljs --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on exceljs.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/GHSA-2j2j-8rrv-264g (OSV record GHSA-2j2j-8rrv-264g lists affected ranges: npm exceljs >=0 <1.6.0 (fixed))
- Verified: https://github.com/advisories/GHSA-2j2j-8rrv-264g (GitHub-reviewed advisory GHSA-2j2j-8rrv-264g lists affected ranges: npm exceljs >=0 <1.6.0)

Commands are suggestions: review each one before running it.

Loading voting…