EC-CUBE Open redirect vulnerability
CVE-2018-16191GHSA-fcgg-qgxg-2g2x
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (ec-cube/ec-cube 3.0.17), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
Packagist ec-cube/ec-cube
- Affected
- >= 3.0.0, <= 3.0.16
- Fixed in
- 3.0.17
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-fcgg-qgxg-2g2x lists affected ranges: Packagist ec-cube/ec-cube >=3.0.0 <=3.0.16
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 6.1 · CVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N
- EPSS
- CVE-2018-16191: 1.30% estimated exploitation activity in the next 30 days; percentile 70.41 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Open redirect vulnerability in EC-CUBE (EC-CUBE 3.0.0, EC-CUBE 3.0.1, EC-CUBE 3.0.2, EC-CUBE 3.0.3, EC-CUBE 3.0.4, EC-CUBE 3.0.5, EC-CUBE 3.0.6, EC-CUBE 3.0.7, EC-CUBE 3.0.8, EC-CUBE 3.0.9, EC-CUBE 3.0.10, EC-CUBE 3.0.11, EC-CUBE 3.0.12, EC-CUBE 3.0.12-p1, EC-CUBE 3.0.13, EC-CUBE 3.0.14, EC-CUBE 3.0.15, EC-CUBE 3.0.16) allows remote attackers to redirect users to arbitrary web sites and conduct phishing attacks via unspecified vectors.
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 1 · created ·
Published from ghsa record GHSA-fcgg-qgxg-2g2x
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2018-16191 Advisory: EC-CUBE Open redirect vulnerability IDs: CVE-2018-16191, GHSA-fcgg-qgxg-2g2x Record: https://patchnext.com/advisories/cve-2018-16191 (revision 1, source checked 26 Oct 2026, 14:26 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Medium (CVSS 6.1) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: ec-cube/ec-cube 3.0.17. A vendor fix does not mean a deployment is fixed. ## Affected components - Packagist ec-cube/ec-cube: affected >= 3.0.0, <= 3.0.16; fixed in 3.0.17 ## Suggested inspection (read-only) - Packagist ec-cube/ec-cube: check the installed version with your package manager. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on ec-cube/ec-cube. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-fcgg-qgxg-2g2x (GitHub-reviewed advisory GHSA-fcgg-qgxg-2g2x lists affected ranges: Packagist ec-cube/ec-cube >=3.0.0 <=3.0.16) Commands are suggestions: review each one before running it.
Loading voting…