Skip to content

← Actionable
High, CVSS 7.5

Opencast publishes global system account credentials

CVE-2018-16153GHSA-hcxx-mp6g-6gr9

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (org.opencastproject:opencast-common 10.6), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
7.5 · CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N
EPSS
  • CVE-2018-16153: 0.83% estimated exploitation activity in the next 30 days; percentile 57.57 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

The issue was mostly mitigated before, drastically reducing the risk. See references below for more information. Impact Opencast before version 10.6 will try to authenticate against any external services listed in a media package when it is trying to access the files, sending the global system user's credentials, regardless of the target being part of the Opencast cluster or not. Previous mitigations already prevented clear text authentications for such requests (e.g. HTTP Basic authentication), but with enough malicious intent, even hashed credentials can be broken. Patches Opencast 10.6 will now send authentication requests only against servers which are part of the Opencast cluster, preventing external services from getting any form of authentication attempt in the first place. Workarounds No workaround available. References - Patch fixing the issue - Original security notice - Original security mitigation For more information If you have any questions or comments about this…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 1 · created ·

    Published from ghsa record GHSA-hcxx-mp6g-6gr9

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2018-16153

Advisory: Opencast publishes global system account credentials
IDs: CVE-2018-16153, GHSA-hcxx-mp6g-6gr9
Record: https://patchnext.com/advisories/cve-2018-16153 (revision 1, source checked 26 Oct 2026, 16:21 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: High (CVSS 7.5)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: org.opencastproject:opencast-common 10.6. A vendor fix does not mean a deployment is fixed.

## Affected components
- Maven org.opencastproject:opencast-common: affected < 10.6; fixed in 10.6

## Suggested inspection (read-only)
- Maven org.opencastproject:opencast-common: check the installed version with your package manager.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on org.opencastproject:opencast-common.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-hcxx-mp6g-6gr9 (GitHub-reviewed advisory GHSA-hcxx-mp6g-6gr9 lists affected ranges: Maven org.opencastproject:opencast-common >=0 <10.6)

Commands are suggestions: review each one before running it.

Loading voting…