Skip to content

← Actionable
High, CVSS 7.5

Insufficient Entropy in DotNetNuke

CVE-2018-15812GHSA-pf46-gqg9-j3v3

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (dotnetnuke.core 9.2.2), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
7.5 · CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N
EPSS
  • CVE-2018-15812: 47.19% estimated exploitation activity in the next 30 days; percentile 98.84 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

DNN (aka DotNetNuke) 9.2 through 9.2.1 incorrectly converts encryption key source values, resulting in lower than expected entropy.

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 1 · created ·

    Published from ghsa record GHSA-pf46-gqg9-j3v3

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2018-15812

Advisory: Insufficient Entropy in DotNetNuke
IDs: CVE-2018-15812, GHSA-pf46-gqg9-j3v3
Record: https://patchnext.com/advisories/cve-2018-15812 (revision 1, source checked 26 Oct 2026, 16:58 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: High (CVSS 7.5)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: dotnetnuke.core 9.2.2. A vendor fix does not mean a deployment is fixed.

## Affected components
- NuGet dotnetnuke.core: affected >= 9.2.0, < 9.2.2; fixed in 9.2.2

## Suggested inspection (read-only)
- NuGet dotnetnuke.core: check the installed version with your package manager.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on dotnetnuke.core.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-pf46-gqg9-j3v3 (GitHub-reviewed advisory GHSA-pf46-gqg9-j3v3 lists affected ranges: NuGet dotnetnuke.core >=9.2.0 <9.2.2)

Commands are suggestions: review each one before running it.

Loading voting…