Electron webPreferences vulnerability can be used to perform remote code execution
CVE-2018-15685GHSA-hv9c-qwqg-qj3v
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (electron 3.0.0-beta.7, 2.0.8, 1.8.8, 1.7.16), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
npm electron
- Affected
- >= 1.7.0, < 1.7.16>= 1.8.0, < 1.8.8>= 2.0.0, < 2.0.8>= 3.0.0-beta.1, < 3.0.0-beta.7
- Fixed in
- 3.0.0-beta.7, 1.8.8, 2.0.8, 1.7.16
Sources
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-hv9c-qwqg-qj3v lists affected ranges: npm electron >=1.7.0 =1.8.0 =2.0.0 =3.0.0-beta.1 <3.0.0-beta.7 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-hv9c-qwqg-qj3v lists affected ranges: npm electron >=1.7.0 =1.8.0 =2.0.0 =3.0.0-beta.1 <3.0.0-beta.7
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 8.1 · CVSS:3.0/AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:H/A:H
- EPSS
- CVE-2018-15685: 10.30% estimated exploitation activity in the next 30 days; percentile 95.70 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
GitHub Electron 1.7.15, 1.8.7, 2.0.7, and 3.0.0-beta.6, in certain scenarios involving IFRAME elements and "nativeWindowOpen: true" or "sandbox: true" options, is affected by a webPreferences vulnerability that can be leveraged to perform remote code execution. More information to determine if you are impacted can be found on the electron blog. Recommendation Upgrade Electron to =3.0.0-beta.7, =2.0.8, =1.8.8, or =1.7.16.
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 2 · amended ·
Amended from ghsa record GHSA-hv9c-qwqg-qj3v
- Revision 1 · created ·
Published from osv record GHSA-hv9c-qwqg-qj3v
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2018-15685 Advisory: Electron webPreferences vulnerability can be used to perform remote code execution IDs: CVE-2018-15685, GHSA-hv9c-qwqg-qj3v Record: https://patchnext.com/advisories/cve-2018-15685 (revision 2, source checked 26 Oct 2026, 12:16 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: High (CVSS 8.1) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: electron 3.0.0-beta.7, 2.0.8, 1.8.8, 1.7.16. A vendor fix does not mean a deployment is fixed. ## Affected components - npm electron: affected >= 1.7.0, < 1.7.16; >= 1.8.0, < 1.8.8; >= 2.0.0, < 2.0.8; >= 3.0.0-beta.1, < 3.0.0-beta.7; fixed in 3.0.0-beta.7, 1.8.8, 2.0.8, 1.7.16 ## Suggested inspection (read-only) - `npm ls electron --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on electron. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://osv.dev/vulnerability/GHSA-hv9c-qwqg-qj3v (OSV record GHSA-hv9c-qwqg-qj3v lists affected ranges: npm electron >=1.7.0 =1.8.0 =2.0.0 =3.0.0-beta.1 <3.0.0-beta.7 (fixed)) - Verified: https://github.com/advisories/GHSA-hv9c-qwqg-qj3v (GitHub-reviewed advisory GHSA-hv9c-qwqg-qj3v lists affected ranges: npm electron >=1.7.0 =1.8.0 =2.0.0 =3.0.0-beta.1 <3.0.0-beta.7) Commands are suggestions: review each one before running it.
Loading voting…