Gogs and Gitea SSRF Vulnerability
CVE-2018-15192GHSA-fg3x-rwq9-74cw
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (gogs.io/gogs 0.12.0; code.gitea.io/gitea 1.16.0-rc1), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
Go gogs.io/gogs
- Affected
- < 0.12.0
- Fixed in
- 0.12.0
- Affected
- < 1.16.0-rc1
- Fixed in
- 1.16.0-rc1
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-fg3x-rwq9-74cw lists affected ranges: Go code.gitea.io/gitea >=0 =0 <0.12.0
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 8.6 · CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:C/C:H/I:N/A:N
- EPSS
- CVE-2018-15192: 2.12% estimated exploitation activity in the next 30 days; percentile 81.90 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
An SSRF vulnerability in webhooks in Gitea through 1.5.0-rc2 and Gogs through 0.11.53 allows remote attackers to access intranet services.
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 1 · created ·
Published from ghsa record GHSA-fg3x-rwq9-74cw
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2018-15192 Advisory: Gogs and Gitea SSRF Vulnerability IDs: CVE-2018-15192, GHSA-fg3x-rwq9-74cw Record: https://patchnext.com/advisories/cve-2018-15192 (revision 1, source checked 26 Oct 2026, 14:59 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: High (CVSS 8.6) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: gogs.io/gogs 0.12.0; code.gitea.io/gitea 1.16.0-rc1. A vendor fix does not mean a deployment is fixed. ## Affected components - Go gogs.io/gogs: affected < 0.12.0; fixed in 0.12.0 - Go code.gitea.io/gitea: affected < 1.16.0-rc1; fixed in 1.16.0-rc1 ## Suggested inspection (read-only) - Go gogs.io/gogs: check the installed version with your package manager. - Go code.gitea.io/gitea: check the installed version with your package manager. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on gogs.io/gogs, code.gitea.io/gitea. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-fg3x-rwq9-74cw (GitHub-reviewed advisory GHSA-fg3x-rwq9-74cw lists affected ranges: Go code.gitea.io/gitea >=0 =0 <0.12.0) Commands are suggestions: review each one before running it.
Loading voting…