Symfony HTTP Foundation web cache poisoning
CVE-2018-14773GHSA-8wgj-6wx8-h5hq
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (symfony/symfony 4.1.3, 4.0.14, 3.4.14, 3.3.18, 2.8.44, 2.7.49; symfony/http-foundation 4.1.3, 4.0.14, 3.4.14, 3.3.18, 2.8.44, 2.7.49), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
Packagist symfony/symfony
- Affected
- >= 2.7.0, < 2.7.49>= 2.8.0, < 2.8.44>= 3.0.0, < 3.3.18>= 3.4.0, < 3.4.14>= 4.0.0, < 4.0.14>= 4.1.0, < 4.1.3
- Fixed in
- 3.4.14, 4.0.14, 4.1.3, 2.7.49, 2.8.44, 3.3.18
Packagist symfony/http-foundation
- Affected
- >= 2.7.0, < 2.7.49>= 2.8.0, < 2.8.44>= 3.0.0, < 3.3.18>= 3.4.0, < 3.4.14>= 4.0.0, < 4.0.14>= 4.1.0, < 4.1.3
- Fixed in
- 3.4.14, 4.0.14, 4.1.3, 2.7.49, 2.8.44, 3.3.18
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-8wgj-6wx8-h5hq lists affected ranges: Packagist symfony/http-foundation >=2.7.0 =2.8.0 =3.0.0 =3.4.0 =4.0.0 =4.1.0 =2.7.0 =2.8.0 =3.0.0 =3.4.0 =4.0.0 =4.1.0 <4.1.3
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 6.5 · CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:H/A:N
- EPSS
- CVE-2018-14773: 57.64% estimated exploitation activity in the next 30 days; percentile 99.08 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
An issue was discovered in Http Foundation in Symfony 2.7.0 through 2.7.48, 2.8.0 through 2.8.43, 3.3.0 through 3.3.17, 3.4.0 through 3.4.13, 4.0.0 through 4.0.13, and 4.1.0 through 4.1.2. It arises from support for a (legacy) IIS header that lets users override the path in the request URL via the X-Original-URL or X-Rewrite-URL HTTP request header. These headers are designed for IIS support, but it's not verified that the server is in fact running IIS, which means anybody who can send these requests to an application can trigger this. This affects \Symfony\Component\HttpFoundation\Request::prepareRequestUri() where X-Original-URL and XREWRITEURL are both used. The fix drops support for these methods so that they cannot be used as attack vectors such as web cache poisoning.
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 1 · created ·
Published from ghsa record GHSA-8wgj-6wx8-h5hq
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2018-14773 Advisory: Symfony HTTP Foundation web cache poisoning IDs: CVE-2018-14773, GHSA-8wgj-6wx8-h5hq Record: https://patchnext.com/advisories/cve-2018-14773 (revision 1, source checked 26 Oct 2026, 14:16 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Medium (CVSS 6.5) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: symfony/symfony 4.1.3, 4.0.14, 3.4.14, 3.3.18, 2.8.44, 2.7.49; symfony/http-foundation 4.1.3, 4.0.14, 3.4.14, 3.3.18, 2.8.44, 2.7.49. A vendor fix does not mean a deployment is fixed. ## Affected components - Packagist symfony/symfony: affected >= 2.7.0, < 2.7.49; >= 2.8.0, < 2.8.44; >= 3.0.0, < 3.3.18; >= 3.4.0, < 3.4.14; >= 4.0.0, < 4.0.14; >= 4.1.0, < 4.1.3; fixed in 3.4.14, 4.0.14, 4.1.3, 2.7.49, 2.8.44, 3.3.18 - Packagist symfony/http-foundation: affected >= 2.7.0, < 2.7.49; >= 2.8.0, < 2.8.44; >= 3.0.0, < 3.3.18; >= 3.4.0, < 3.4.14; >= 4.0.0, < 4.0.14; >= 4.1.0, < 4.1.3; fixed in 3.4.14, 4.0.14, 4.1.3, 2.7.49, 2.8.44, 3.3.18 ## Suggested inspection (read-only) - Packagist symfony/symfony: check the installed version with your package manager. - Packagist symfony/http-foundation: check the installed version with your package manager. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on symfony/symfony, symfony/http-foundation. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-8wgj-6wx8-h5hq (GitHub-reviewed advisory GHSA-8wgj-6wx8-h5hq lists affected ranges: Packagist symfony/http-foundation >=2.7.0 =2.8.0 =3.0.0 =3.4.0 =4.0.0 =4.1.0 =2.7.0 =2.8.0 =3.0.0 =3.4.0 =4.0.0 =4.1.0 <4.1.3) Commands are suggestions: review each one before running it.
Loading voting…