Skip to content

← Actionable
Critical, CVSS 9.8Exploited · CISA KEV

Richfaces vulnerable to arbitrary code execution

CVE-2018-14667GHSA-j7mw-7crr-658v

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (org.richfaces:richfaces-core 3.3.4), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

Sources

Severity and exploitation
Exploitation
Confirmed: listed in the CISA Known Exploited Vulnerabilities catalog.
CVSS
9.8 · CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H/E:H
EPSS
  • CVE-2018-14667: 74.20% estimated exploitation activity in the next 30 days; percentile 99.49 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

The RichFaces Framework 3.X through 3.3.4 is vulnerable to Expression Language (EL) injection via the UserResource resource. A remote, unauthenticated attacker could exploit this to execute arbitrary code using a chain of java serialized objects via org.ajax4jsf.resource.UserResource$UriData.

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 1 · created ·

    Published from ghsa record GHSA-j7mw-7crr-658v

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2018-14667

Advisory: Richfaces vulnerable to arbitrary code execution
IDs: CVE-2018-14667, GHSA-j7mw-7crr-658v
Record: https://patchnext.com/advisories/cve-2018-14667 (revision 1, source checked 26 Oct 2026, 16:40 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Critical (CVSS 9.8)
Exploitation: confirmed: listed in the CISA Known Exploited Vulnerabilities catalog.
Vendor response: Vendor fix available; fixed versions by package: org.richfaces:richfaces-core 3.3.4. A vendor fix does not mean a deployment is fixed.

## Affected components
- Maven org.richfaces:richfaces-core: affected < 3.3.4; fixed in 3.3.4

## Suggested inspection (read-only)
- Maven org.richfaces:richfaces-core: check the installed version with your package manager.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on org.richfaces:richfaces-core.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://www.cisa.gov/known-exploited-vulnerabilities-catalog (CISA added CVE-2018-14667 to the Known Exploited Vulnerabilities catalog on 2023-09-28.)
- Verified: https://github.com/advisories/GHSA-j7mw-7crr-658v (GitHub-reviewed advisory GHSA-j7mw-7crr-658v lists affected ranges: Maven org.richfaces:richfaces-core >=0 <3.3.4)

Commands are suggestions: review each one before running it.

Loading voting…