Skip to content

← Actionable
High, CVSS 8.1

Improper Authentication in Keycloak

CVE-2018-14637GHSA-gf2j-7qwg-4f5x

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (org.keycloak:keycloak-core 4.6.0), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
8.1 · CVSS:3.0/AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:H/A:H
EPSS
  • CVE-2018-14637: 0.81% estimated exploitation activity in the next 30 days; percentile 57.08 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

The SAML broker consumer endpoint in Keycloak before version 4.6.0.Final ignores expiration conditions on SAML assertions. An attacker can exploit this vulnerability to perform a replay attack.

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 1 · created ·

    Published from ghsa record GHSA-gf2j-7qwg-4f5x

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2018-14637

Advisory: Improper Authentication in Keycloak
IDs: CVE-2018-14637, GHSA-gf2j-7qwg-4f5x
Record: https://patchnext.com/advisories/cve-2018-14637 (revision 1, source checked 26 Oct 2026, 15:53 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: High (CVSS 8.1)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: org.keycloak:keycloak-core 4.6.0. A vendor fix does not mean a deployment is fixed.

## Affected components
- Maven org.keycloak:keycloak-core: affected < 4.6.0; fixed in 4.6.0

## Suggested inspection (read-only)
- Maven org.keycloak:keycloak-core: check the installed version with your package manager.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on org.keycloak:keycloak-core.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-gf2j-7qwg-4f5x (GitHub-reviewed advisory GHSA-gf2j-7qwg-4f5x lists affected ranges: Maven org.keycloak:keycloak-core >=0 <4.6.0)

Commands are suggestions: review each one before running it.

Loading voting…