Skip to content

← Actionable
Medium, CVSS 6.1

Moodle Cross-site Scripting

CVE-2018-14631GHSA-gqrp-qhv8-phrv

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (moodle/moodle 3.5.2, 3.4.5, 3.3.8), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • Packagist moodle/moodle

    Affected
    >= 3.3, < 3.3.8>= 3.4, < 3.4.5>= 3.5, < 3.5.2
    Fixed in
    3.5.2, 3.3.8, 3.4.5

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
6.1 · CVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N
EPSS
  • CVE-2018-14631: 2.08% estimated exploitation activity in the next 30 days; percentile 81.55 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

moodle before versions 3.5.2, 3.4.5, 3.3.8 is vulnerable to a boost theme - blog search GET parameter insufficiently filtered. The breadcrumb navigation provided by Boost theme when displaying search results of a blog were insufficiently filtered, which could result in reflected XSS if a user followed a malicious link containing JavaScript in the search parameter.

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 1 · created ·

    Published from ghsa record GHSA-gqrp-qhv8-phrv

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2018-14631

Advisory: Moodle Cross-site Scripting
IDs: CVE-2018-14631, GHSA-gqrp-qhv8-phrv
Record: https://patchnext.com/advisories/cve-2018-14631 (revision 1, source checked 26 Oct 2026, 14:20 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Medium (CVSS 6.1)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: moodle/moodle 3.5.2, 3.4.5, 3.3.8. A vendor fix does not mean a deployment is fixed.

## Affected components
- Packagist moodle/moodle: affected >= 3.3, < 3.3.8; >= 3.4, < 3.4.5; >= 3.5, < 3.5.2; fixed in 3.5.2, 3.3.8, 3.4.5

## Suggested inspection (read-only)
- Packagist moodle/moodle: check the installed version with your package manager.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on moodle/moodle.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-gqrp-qhv8-phrv (GitHub-reviewed advisory GHSA-gqrp-qhv8-phrv lists affected ranges: Packagist moodle/moodle >=3.3 =3.4 =3.5 <3.5.2)

Commands are suggestions: review each one before running it.

Loading voting…