Mitmweb in mitmproxy allows DNS Rebinding attacks
CVE-2018-14505GHSA-6m53-c78q-7qmg
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (mitmproxy 4.0.4), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
PyPI mitmproxy
- Affected
- < 4.0.4
- Fixed in
- 4.0.4
Sources
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-6m53-c78q-7qmg lists affected ranges: PyPI mitmproxy >=0 <4.0.4 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-6m53-c78q-7qmg lists affected ranges: PyPI mitmproxy >=0 <4.0.4
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS 4.0
- 9.2 · CVSS:4.0/AV:N/AC:L/AT:P/PR:N/UI:N/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N · score source
- EPSS
- CVE-2018-14505: 3.35% estimated exploitation activity in the next 30 days; percentile 88.69 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
mitmweb in mitmproxy before v4.0.4 allows DNS Rebinding attacks, related to tools/web/app.py.
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 3 · amended ·
Amended from ghsa record GHSA-6m53-c78q-7qmg
- Revision 2 · amended ·
Reviewed OSV alias/range/CVSS4 correction; package source scopes and original publication preserved. No customer finding resolved.
- Revision 1 · created ·
Published from osv record GHSA-6m53-c78q-7qmg
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2018-14505 Advisory: Mitmweb in mitmproxy allows DNS Rebinding attacks IDs: CVE-2018-14505, GHSA-6m53-c78q-7qmg Record: https://patchnext.com/advisories/cve-2018-14505 (revision 3, source checked 26 Oct 2026, 13:21 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Critical (CVSS 9.2) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: mitmproxy 4.0.4. A vendor fix does not mean a deployment is fixed. ## Affected components - PyPI mitmproxy: affected < 4.0.4; fixed in 4.0.4 ## Suggested inspection (read-only) - `python -m pip show mitmproxy`: prints the installed version. Run with the environment that serves production active. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on mitmproxy. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://osv.dev/vulnerability/GHSA-6m53-c78q-7qmg (OSV record GHSA-6m53-c78q-7qmg lists affected ranges: PyPI mitmproxy >=0 <4.0.4 (fixed)) - Verified: https://github.com/advisories/GHSA-6m53-c78q-7qmg (GitHub-reviewed advisory GHSA-6m53-c78q-7qmg lists affected ranges: PyPI mitmproxy >=0 <4.0.4) Commands are suggestions: review each one before running it.
Loading voting…