org.apache.tika:tika-parsers has an Infinite Loop vulnerability
CVE-2018-1339GHSA-p699-3wgc-7h72
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (org.apache.tika:tika-parsers 1.18), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
Maven org.apache.tika:tika-parsers
- Affected
- < 1.18
- Fixed in
- 1.18
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-p699-3wgc-7h72 lists affected ranges: Maven org.apache.tika:tika-parsers >=0 <1.18
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 5.5 · CVSS:3.0/AV:L/AC:L/PR:N/UI:R/S:U/C:N/I:N/A:H
- EPSS
- CVE-2018-1339: 2.56% estimated exploitation activity in the next 30 days; percentile 85.10 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Versions of the package org.apache.tika:tika-parsers before version 1.18 are vulnerable to Denial of Service (DoS) via a carefully crafted (or fuzzed) file that can trigger an infinite loop via the ChmParser.
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 1 · created ·
Published from ghsa record GHSA-p699-3wgc-7h72
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2018-1339 Advisory: org.apache.tika:tika-parsers has an Infinite Loop vulnerability IDs: CVE-2018-1339, GHSA-p699-3wgc-7h72 Record: https://patchnext.com/advisories/cve-2018-1339 (revision 1, source checked 26 Oct 2026, 16:10 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Medium (CVSS 5.5) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: org.apache.tika:tika-parsers 1.18. A vendor fix does not mean a deployment is fixed. ## Affected components - Maven org.apache.tika:tika-parsers: affected < 1.18; fixed in 1.18 ## Suggested inspection (read-only) - Maven org.apache.tika:tika-parsers: check the installed version with your package manager. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on org.apache.tika:tika-parsers. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-p699-3wgc-7h72 (GitHub-reviewed advisory GHSA-p699-3wgc-7h72 lists affected ranges: Maven org.apache.tika:tika-parsers >=0 <1.18) Commands are suggestions: review each one before running it.
Loading voting…