In Apache Tomcat there is an improper handing of overflow in the UTF-8 decoder
CVE-2018-1336GHSA-m59c-jpc8-m2x4
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (org.apache.tomcat.embed:tomcat-embed-core 9.0.8, 8.5.31, 8.0.51, 7.0.87), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
Maven org.apache.tomcat.embed:tomcat-embed-core
- Affected
- >= 8.5.0, < 8.5.31>= 7.0.28, < 7.0.87>= 9.0.0.M9, <= 9.0.7>= 8.0.0RC1, < 8.0.51
- Fixed in
- 8.5.31, 7.0.87, 9.0.8, 8.0.51
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-m59c-jpc8-m2x4 lists affected ranges: Maven org.apache.tomcat.embed:tomcat-embed-core >=8.5.0 =7.0.28 =9.0.0.M9 =8.0.0RC1 <8.0.51
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 7.5 · CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H
- EPSS
- CVE-2018-1336: 20.35% estimated exploitation activity in the next 30 days; percentile 97.49 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
An improper handing of overflow in the UTF-8 decoder with supplementary characters can lead to an infinite loop in the decoder causing a Denial of Service. Versions Affected: Apache Tomcat 9.0.0.M9 to 9.0.7, 8.5.0 to 8.5.30, 8.0.0.RC1 to 8.0.51, and 7.0.28 to 7.0.86.
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 1 · created ·
Published from ghsa record GHSA-m59c-jpc8-m2x4
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2018-1336 Advisory: In Apache Tomcat there is an improper handing of overflow in the UTF-8 decoder IDs: CVE-2018-1336, GHSA-m59c-jpc8-m2x4 Record: https://patchnext.com/advisories/cve-2018-1336 (revision 1, source checked 26 Oct 2026, 16:26 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: High (CVSS 7.5) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: org.apache.tomcat.embed:tomcat-embed-core 9.0.8, 8.5.31, 8.0.51, 7.0.87. A vendor fix does not mean a deployment is fixed. ## Affected components - Maven org.apache.tomcat.embed:tomcat-embed-core: affected >= 8.5.0, < 8.5.31; >= 7.0.28, < 7.0.87; >= 9.0.0.M9, <= 9.0.7; >= 8.0.0RC1, < 8.0.51; fixed in 8.5.31, 7.0.87, 9.0.8, 8.0.51 ## Suggested inspection (read-only) - Maven org.apache.tomcat.embed:tomcat-embed-core: check the installed version with your package manager. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on org.apache.tomcat.embed:tomcat-embed-core. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-m59c-jpc8-m2x4 (GitHub-reviewed advisory GHSA-m59c-jpc8-m2x4 lists affected ranges: Maven org.apache.tomcat.embed:tomcat-embed-core >=8.5.0 =7.0.28 =9.0.0.M9 =8.0.0RC1 <8.0.51) Commands are suggestions: review each one before running it.
Loading voting…