Skip to content

← Actionable
Medium, CVSS 5.5

Apache Commons Compress vulnerable to denial of service due to infinite loop

CVE-2018-1324GHSA-h436-432x-8fvx

What to do

Partial vendor fix. Follow the primary source's mitigation guidance and check back for a fix.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • Maven io.takari:commons-compress

    Affected
    >= 1.12, <= 1.12
    Fixed in
    no fixed version recorded
  • Maven com.liferay:com.liferay.portal.tools.bundle.support

    Affected
    >= 3.2.7, < 3.7.4
    Fixed in
    3.7.4
  • Maven org.apache.commons:commons-compress

    Affected
    >= 1.11, < 1.16
    Fixed in
    1.16

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
5.5 · CVSS:3.0/AV:L/AC:L/PR:N/UI:R/S:U/C:N/I:N/A:H
EPSS
  • CVE-2018-1324: 3.66% estimated exploitation activity in the next 30 days; percentile 89.63 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

A specially crafted ZIP archive can be used to cause an infinite loop inside of Apache Commons Compress' extra field parser used by the ZipFile and ZipArchiveInputStream classes in versions 1.11 to 1.15. This can be used to mount a denial of service attack against services that use Compress' zip package.

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 1 · created ·

    Published from ghsa record GHSA-h436-432x-8fvx

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2018-1324

Advisory: Apache Commons Compress vulnerable to denial of service due to infinite loop
IDs: CVE-2018-1324, GHSA-h436-432x-8fvx
Record: https://patchnext.com/advisories/cve-2018-1324 (revision 1, source checked 26 Oct 2026, 16:26 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Medium (CVSS 5.5)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Partial vendor fix; fixed versions by package: com.liferay:com.liferay.portal.tools.bundle.support 3.7.4; org.apache.commons:commons-compress 1.16. A vendor fix does not mean a deployment is fixed.

## Affected components
- Maven io.takari:commons-compress: affected >= 1.12, <= 1.12
- Maven com.liferay:com.liferay.portal.tools.bundle.support: affected >= 3.2.7, < 3.7.4; fixed in 3.7.4
- Maven org.apache.commons:commons-compress: affected >= 1.11, < 1.16; fixed in 1.16

## Suggested inspection (read-only)
- Maven io.takari:commons-compress: check the installed version with your package manager.
- Maven com.liferay:com.liferay.portal.tools.bundle.support: check the installed version with your package manager.
- Maven org.apache.commons:commons-compress: check the installed version with your package manager.

## Supported action
No complete vendor fix is recorded. Follow the primary source's mitigation guidance and check this record again before closing anything.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on io.takari:commons-compress, com.liferay:com.liferay.portal.tools.bundle.support, org.apache.commons:commons-compress.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-h436-432x-8fvx (GitHub-reviewed advisory GHSA-h436-432x-8fvx lists affected ranges: Maven org.apache.commons:commons-compress >=1.11 =3.2.7 =1.12 <=1.12)

Commands are suggestions: review each one before running it.

Loading voting…