Skip to content

← Actionable
Medium, CVSS 5.3

Improper Access Control in Apache Derby

CVE-2018-1313GHSA-42xw-p62x-hwcf

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (org.apache.derby:derby 10.14.2.0), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
5.3 · CVSS:3.1/AV:N/AC:H/PR:L/UI:N/S:U/C:N/I:H/A:N
EPSS
  • CVE-2018-1313: 4.59% estimated exploitation activity in the next 30 days; percentile 91.66 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

In Apache Derby 10.3.1.4 to 10.14.1.0, a specially-crafted network packet can be used to request the Derby Network Server to boot a database whose location and contents are under the user's control. If the Derby Network Server is not running with a Java Security Manager policy file, the attack is successful. If the server is using a policy file, the policy file must permit the database location to be read for the attack to work. The default Derby Network Server policy file distributed with the affected releases includes a permissive policy as the default Network Server policy, which allows the attack to work.

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 1 · created ·

    Published from ghsa record GHSA-42xw-p62x-hwcf

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2018-1313

Advisory: Improper Access Control in Apache Derby
IDs: CVE-2018-1313, GHSA-42xw-p62x-hwcf
Record: https://patchnext.com/advisories/cve-2018-1313 (revision 1, source checked 26 Oct 2026, 15:53 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Medium (CVSS 5.3)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: org.apache.derby:derby 10.14.2.0. A vendor fix does not mean a deployment is fixed.

## Affected components
- Maven org.apache.derby:derby: affected >= 10.3.1.4, <= 10.14.1.0; fixed in 10.14.2.0

## Suggested inspection (read-only)
- Maven org.apache.derby:derby: check the installed version with your package manager.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on org.apache.derby:derby.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-42xw-p62x-hwcf (GitHub-reviewed advisory GHSA-42xw-p62x-hwcf lists affected ranges: Maven org.apache.derby:derby >=10.3.1.4 <=10.14.1.0)

Commands are suggestions: review each one before running it.

Loading voting…