Junrar vulnerable to Infinite Loop
CVE-2018-12418GHSA-5xqr-grq4-qwgx
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (com.github.junrar:junrar 1.0.1), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
Maven com.github.junrar:junrar
- Affected
- < 1.0.1
- Fixed in
- 1.0.1
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-5xqr-grq4-qwgx lists affected ranges: Maven com.github.junrar:junrar >=0 <1.0.1
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 5.5 · CVSS:3.0/AV:L/AC:L/PR:N/UI:R/S:U/C:N/I:N/A:H
- EPSS
- CVE-2018-12418: 1.17% estimated exploitation activity in the next 30 days; percentile 67.43 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Archive.java in Junrar before 1.0.1, as used in Apache Tika and other products, is affected by a denial of service vulnerability due to an infinite loop when handling corrupt RAR files.
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 1 · created ·
Published from ghsa record GHSA-5xqr-grq4-qwgx
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2018-12418 Advisory: Junrar vulnerable to Infinite Loop IDs: CVE-2018-12418, GHSA-5xqr-grq4-qwgx Record: https://patchnext.com/advisories/cve-2018-12418 (revision 1, source checked 26 Oct 2026, 15:53 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Medium (CVSS 5.5) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: com.github.junrar:junrar 1.0.1. A vendor fix does not mean a deployment is fixed. ## Affected components - Maven com.github.junrar:junrar: affected < 1.0.1; fixed in 1.0.1 ## Suggested inspection (read-only) - Maven com.github.junrar:junrar: check the installed version with your package manager. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on com.github.junrar:junrar. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-5xqr-grq4-qwgx (GitHub-reviewed advisory GHSA-5xqr-grq4-qwgx lists affected ranges: Maven com.github.junrar:junrar >=0 <1.0.1) Commands are suggestions: review each one before running it.
Loading voting…