Skip to content

← Actionable
High, CVSS 7.0

Phusion Passenger Race Condition Allows Privilege Escalation

CVE-2018-12029GHSA-jjcj-fgfm-9g9r

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (passenger 5.3.2), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • RubyGems passenger

    Affected
    >= 3.0.0, < 5.3.2
    Fixed in
    5.3.2

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
7.0 · CVSS:3.0/AV:L/AC:H/PR:L/UI:N/S:U/C:H/I:H/A:H
EPSS
  • CVE-2018-12029: 0.27% estimated exploitation activity in the next 30 days; percentile 19.84 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

A race condition in the nginx module in Phusion Passenger 3.x through 5.x before 5.3.2 allows local escalation of privileges when a non-standard passengerinstanceregistrydir with insufficiently strict permissions is configured. Replacing a file with a symlink after the file was created, but before it was chowned, leads to the target of the link being chowned via the path. Targeting sensitive files such as root's crontab file allows privilege escalation.

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 1 · created ·

    Published from ghsa record GHSA-jjcj-fgfm-9g9r

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2018-12029

Advisory: Phusion Passenger Race Condition Allows Privilege Escalation
IDs: CVE-2018-12029, GHSA-jjcj-fgfm-9g9r
Record: https://patchnext.com/advisories/cve-2018-12029 (revision 1, source checked 26 Oct 2026, 15:47 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: High (CVSS 7.0)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: passenger 5.3.2. A vendor fix does not mean a deployment is fixed.

## Affected components
- RubyGems passenger: affected >= 3.0.0, < 5.3.2; fixed in 5.3.2

## Suggested inspection (read-only)
- RubyGems passenger: check the installed version with your package manager.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on passenger.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-jjcj-fgfm-9g9r (GitHub-reviewed advisory GHSA-jjcj-fgfm-9g9r lists affected ranges: RubyGems passenger >=3.0.0 <5.3.2)

Commands are suggestions: review each one before running it.

Loading voting…