Skip to content

← Actionable
High, CVSS 8.8

Insecure Permissions in Phusion Passenger

CVE-2018-12027GHSA-whfx-877c-5p28

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (passenger 5.3.2), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • RubyGems passenger

    Affected
    >= 5.3.0, < 5.3.2
    Fixed in
    5.3.2

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
8.8 · CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H
EPSS
  • CVE-2018-12027: 1.07% estimated exploitation activity in the next 30 days; percentile 64.92 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

An Insecure Permissions vulnerability in SpawningKit in Phusion Passenger 5.3.x before 5.3.2 causes information disclosure in the following situation: given a Passenger-spawned application process that reports that it listens on a certain Unix domain socket, if any of the parent directories of said socket are writable by a normal user that is not the application's user, then that non-application user can swap that directory with something else, resulting in traffic being redirected to a non-application user's process through an alternative Unix domain socket.

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 1 · created ·

    Published from ghsa record GHSA-whfx-877c-5p28

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2018-12027

Advisory: Insecure Permissions in Phusion Passenger
IDs: CVE-2018-12027, GHSA-whfx-877c-5p28
Record: https://patchnext.com/advisories/cve-2018-12027 (revision 1, source checked 26 Oct 2026, 15:47 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: High (CVSS 8.8)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: passenger 5.3.2. A vendor fix does not mean a deployment is fixed.

## Affected components
- RubyGems passenger: affected >= 5.3.0, < 5.3.2; fixed in 5.3.2

## Suggested inspection (read-only)
- RubyGems passenger: check the installed version with your package manager.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on passenger.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-whfx-877c-5p28 (GitHub-reviewed advisory GHSA-whfx-877c-5p28 lists affected ranges: RubyGems passenger >=5.3.0 <5.3.2)

Commands are suggestions: review each one before running it.

Loading voting…