Singularity Incorrect Access Control
CVE-2018-12021GHSA-4x32-h296-rg6j
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (github.com/hpcng/singularity 2.5.2), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
Go github.com/hpcng/singularity
- Affected
- >= 2.3.0, <= 2.5.1
- Fixed in
- 2.5.2
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-4x32-h296-rg6j lists affected ranges: Go github.com/hpcng/singularity >=2.3.0 <=2.5.1
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 6.5 · CVSS:3.0/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:N/A:N
- EPSS
- CVE-2018-12021: 1.47% estimated exploitation activity in the next 30 days; percentile 73.69 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Singularity 2.3.0 through 2.5.1 is affected by an incorrect access control on systems supporting overlay file system. When using the overlay option, a malicious user may access sensitive information by exploiting a few specific Singularity features.
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 1 · created ·
Published from ghsa record GHSA-4x32-h296-rg6j
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2018-12021 Advisory: Singularity Incorrect Access Control IDs: CVE-2018-12021, GHSA-4x32-h296-rg6j Record: https://patchnext.com/advisories/cve-2018-12021 (revision 1, source checked 26 Oct 2026, 14:59 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Medium (CVSS 6.5) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: github.com/hpcng/singularity 2.5.2. A vendor fix does not mean a deployment is fixed. ## Affected components - Go github.com/hpcng/singularity: affected >= 2.3.0, <= 2.5.1; fixed in 2.5.2 ## Suggested inspection (read-only) - Go github.com/hpcng/singularity: check the installed version with your package manager. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on github.com/hpcng/singularity. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-4x32-h296-rg6j (GitHub-reviewed advisory GHSA-4x32-h296-rg6j lists affected ranges: Go github.com/hpcng/singularity >=2.3.0 <=2.5.1) Commands are suggestions: review each one before running it.
Loading voting…