Moderate severity vulnerability that affects org.springframework.boot:spring-boot
CVE-2018-1196GHSA-xx65-cc7g-9pfp
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (org.springframework.boot:spring-boot 1.5.10), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
Maven org.springframework.boot:spring-boot
- Affected
- >= 1.5.0, < 1.5.10
- Fixed in
- 1.5.10
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-xx65-cc7g-9pfp lists affected ranges: Maven org.springframework.boot:spring-boot >=1.5.0 <1.5.10
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 5.9 · CVSS:3.0/AV:N/AC:H/PR:N/UI:N/S:U/C:N/I:H/A:N
- EPSS
- CVE-2018-1196: 1.21% estimated exploitation activity in the next 30 days; percentile 68.53 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Spring Boot supports an embedded launch script that can be used to easily run the application as a systemd or init.d linux service. The script included with Spring Boot 1.5.9 and earlier and 2.0.0.M1 through 2.0.0.M7 is susceptible to a symlink attack which allows the "runuser" to overwrite and take ownership of any file on the same system. In order to instigate the attack, the application must be installed as a service and the "runuser" requires shell access to the server. Spring Boot application that are not installed as a service, or are not using the embedded launch script are not susceptible.
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 1 · created ·
Published from ghsa record GHSA-xx65-cc7g-9pfp
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2018-1196 Advisory: Moderate severity vulnerability that affects org.springframework.boot:spring-boot IDs: CVE-2018-1196, GHSA-xx65-cc7g-9pfp Record: https://patchnext.com/advisories/cve-2018-1196 (revision 1, source checked 26 Oct 2026, 16:05 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Medium (CVSS 5.9) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: org.springframework.boot:spring-boot 1.5.10. A vendor fix does not mean a deployment is fixed. ## Affected components - Maven org.springframework.boot:spring-boot: affected >= 1.5.0, < 1.5.10; fixed in 1.5.10 ## Suggested inspection (read-only) - Maven org.springframework.boot:spring-boot: check the installed version with your package manager. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on org.springframework.boot:spring-boot. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-xx65-cc7g-9pfp (GitHub-reviewed advisory GHSA-xx65-cc7g-9pfp lists affected ranges: Maven org.springframework.boot:spring-boot >=1.5.0 <1.5.10) Commands are suggestions: review each one before running it.
Loading voting…