Skip to content

← Actionable
Medium, CVSS 6.1

Pivotal Cloud Foundry UAA XSS on UAA OpenID Connect check session iframe endpoint

CVE-2018-1190GHSA-j97q-9xp9-g5fx

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (org.cloudfoundry.identity:cloudfoundry-identity-server 3.20.2), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
6.1 · CVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N
EPSS
  • CVE-2018-1190: 0.83% estimated exploitation activity in the next 30 days; percentile 57.66 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

An issue was discovered in these Pivotal Cloud Foundry products: all versions prior to cf-release v270, UAA v3.x prior to v3.20.2, and UAA bosh v30.x versions prior to v30.8 and all other versions prior to v45.0. A cross-site scripting (XSS) attack is possible in the clientId parameter of a request to the UAA OpenID Connect check session iframe endpoint used for single logout session management.

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 1 · created ·

    Published from ghsa record GHSA-j97q-9xp9-g5fx

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2018-1190

Advisory: Pivotal Cloud Foundry UAA XSS on UAA OpenID Connect check session iframe endpoint
IDs: CVE-2018-1190, GHSA-j97q-9xp9-g5fx
Record: https://patchnext.com/advisories/cve-2018-1190 (revision 1, source checked 26 Oct 2026, 16:26 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Medium (CVSS 6.1)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: org.cloudfoundry.identity:cloudfoundry-identity-server 3.20.2. A vendor fix does not mean a deployment is fixed.

## Affected components
- Maven org.cloudfoundry.identity:cloudfoundry-identity-server: affected >= 3.0.0, < 3.20.2; fixed in 3.20.2

## Suggested inspection (read-only)
- Maven org.cloudfoundry.identity:cloudfoundry-identity-server: check the installed version with your package manager.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on org.cloudfoundry.identity:cloudfoundry-identity-server.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-j97q-9xp9-g5fx (GitHub-reviewed advisory GHSA-j97q-9xp9-g5fx lists affected ranges: Maven org.cloudfoundry.identity:cloudfoundry-identity-server >=3.0.0 <3.20.2)

Commands are suggestions: review each one before running it.

Loading voting…