Apache Tika is vulnerable to entity expansions which can lead to a denial of service attack
CVE-2018-11796GHSA-h8q5-g2cj-qr5h
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (org.apache.tika:tika-core 1.19.1), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
Maven org.apache.tika:tika-core
- Affected
- >= 0.1, < 1.19.1
- Fixed in
- 1.19.1
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-h8q5-g2cj-qr5h lists affected ranges: Maven org.apache.tika:tika-core >=0.1 <1.19.1
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 7.5 · CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H
- EPSS
- CVE-2018-11796: 7.54% estimated exploitation activity in the next 30 days; percentile 94.52 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
In Apache Tika 1.19 (CVE-2018-11761), we added an entity expansion limit for XML parsing. However, Tika reuses SAXParsers and calls reset() after each parse, which, for Xerces2 parsers, as per the documentation, removes the user-specified SecurityManager and thus removes entity expansion limits after the first parse. Apache Tika versions from 0.1 to 1.19 are therefore still vulnerable to entity expansions which can lead to a denial of service attack. Users should upgrade to 1.19.1 or later.
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 1 · created ·
Published from ghsa record GHSA-h8q5-g2cj-qr5h
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2018-11796 Advisory: Apache Tika is vulnerable to entity expansions which can lead to a denial of service attack IDs: CVE-2018-11796, GHSA-h8q5-g2cj-qr5h Record: https://patchnext.com/advisories/cve-2018-11796 (revision 1, source checked 26 Oct 2026, 15:52 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: High (CVSS 7.5) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: org.apache.tika:tika-core 1.19.1. A vendor fix does not mean a deployment is fixed. ## Affected components - Maven org.apache.tika:tika-core: affected >= 0.1, < 1.19.1; fixed in 1.19.1 ## Suggested inspection (read-only) - Maven org.apache.tika:tika-core: check the installed version with your package manager. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on org.apache.tika:tika-core. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-h8q5-g2cj-qr5h (GitHub-reviewed advisory GHSA-h8q5-g2cj-qr5h lists affected ranges: Maven org.apache.tika:tika-core >=0.1 <1.19.1) Commands are suggestions: review each one before running it.
Loading voting…