Skip to content

← Actionable
High, CVSS 8.1

Improper Authentication in Apache Karaf

CVE-2018-11787GHSA-cq9c-55r7-455x

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (org.apache.karaf:apache-karaf 4.1.1, 4.0.9, 3.0.9), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
8.1 · CVSS:3.0/AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:H/A:H
EPSS
  • CVE-2018-11787: 2.57% estimated exploitation activity in the next 30 days; percentile 85.19 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

In Apache Karaf version prior to 3.0.9, 4.0.9, 4.1.1, when the webconsole feature is installed in Karaf, it is available at .../system/console and requires authentication to access it. One part of the console is a Gogo shell/console that gives access to the command line console of Karaf via a Web browser, and when navigated to it is available at .../system/console/gogo. Trying to go directly to that URL does require authentication. And optional bundle that some applications use is the Pax Web Extender Whiteboard, it is part of the pax-war feature and perhaps others. When it is installed, the Gogo console becomes available at another URL .../gogo/, and that URL is not secured giving access to the Karaf console to unauthenticated users. A mitigation for the issue is to manually stop/uninstall Gogo plugin bundle that is installed with the webconsole feature, although of course this removes the console from the .../system/console application, not only from the unauthenticated endpoint.…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 1 · created ·

    Published from ghsa record GHSA-cq9c-55r7-455x

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2018-11787

Advisory: Improper Authentication in Apache Karaf
IDs: CVE-2018-11787, GHSA-cq9c-55r7-455x
Record: https://patchnext.com/advisories/cve-2018-11787 (revision 1, source checked 26 Oct 2026, 15:53 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: High (CVSS 8.1)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: org.apache.karaf:apache-karaf 4.1.1, 4.0.9, 3.0.9. A vendor fix does not mean a deployment is fixed.

## Affected components
- Maven org.apache.karaf:apache-karaf: affected < 3.0.9; >= 4.0.0, < 4.0.9; >= 4.1.0, <= 4.1.0; fixed in 3.0.9, 4.0.9, 4.1.1

## Suggested inspection (read-only)
- Maven org.apache.karaf:apache-karaf: check the installed version with your package manager.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on org.apache.karaf:apache-karaf.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-cq9c-55r7-455x (GitHub-reviewed advisory GHSA-cq9c-55r7-455x lists affected ranges: Maven org.apache.karaf:apache-karaf >=0 =4.0.0 =4.1.0 <=4.1.0)

Commands are suggestions: review each one before running it.

Loading voting…