Symfony Session Fixation Vulnerability
CVE-2018-11385GHSA-g4rg-rw65-8hfg
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (symfony/symfony 4.0.11, 3.4.11, 3.3.17, 2.8.41, 2.7.48; symfony/security-http 4.0.11, 3.4.11, 3.3.17, 2.8.41, 2.7.48; symfony/security 4.0.11, 3.4.11, 3.3.17, 2.8.41, 2.7.48), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
Packagist symfony/symfony
- Affected
- >= 2.7.0, < 2.7.48>= 2.8.0, < 2.8.41>= 3.4.0, < 3.4.11>= 4.0.0, < 4.0.11>= 3.0.0, < 3.3.17
- Fixed in
- 2.7.48, 4.0.11, 2.8.41, 3.3.17, 3.4.11
Packagist symfony/security-http
- Affected
- >= 2.7.0, < 2.7.48>= 2.8.0, < 2.8.41>= 3.0.0, < 3.3.17>= 3.4.0, < 3.4.11>= 4.0.0, < 4.0.11
- Fixed in
- 2.7.48, 4.0.11, 2.8.41, 3.3.17, 3.4.11
Packagist symfony/security
- Affected
- >= 2.7.0, < 2.7.48>= 2.8.0, < 2.8.41>= 3.0.0, < 3.3.17>= 3.4.0, < 3.4.11>= 4.0.0, < 4.0.11
- Fixed in
- 2.7.48, 4.0.11, 2.8.41, 3.3.17, 3.4.11
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-g4rg-rw65-8hfg lists affected ranges: Packagist symfony/symfony >=2.7.0 =2.8.0 =3.4.0 =4.0.0 =3.0.0 =2.7.0 =2.8.0 =3.0.0 =3.4.0 =4.0.0 =2.7.0 =2.8.0 =3.0.0 =3.4.0 =4.0.0 <4.0.11
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 8.1 · CVSS:3.0/AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:H/A:H
- EPSS
- CVE-2018-11385: 1.97% estimated exploitation activity in the next 30 days; percentile 80.50 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
An issue was discovered in the Security component in Symfony 2.7.x before 2.7.48, 2.8.x before 2.8.41, 3.3.x before 3.3.17, 3.4.x before 3.4.11, and 4.0.x before 4.0.11. A session fixation vulnerability within the "Guard" login feature may allow an attacker to impersonate a victim towards the web application if the session id value was previously known to the attacker.
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 1 · created ·
Published from ghsa record GHSA-g4rg-rw65-8hfg
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2018-11385 Advisory: Symfony Session Fixation Vulnerability IDs: CVE-2018-11385, GHSA-g4rg-rw65-8hfg Record: https://patchnext.com/advisories/cve-2018-11385 (revision 1, source checked 26 Oct 2026, 14:16 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: High (CVSS 8.1) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: symfony/symfony 4.0.11, 3.4.11, 3.3.17, 2.8.41, 2.7.48; symfony/security-http 4.0.11, 3.4.11, 3.3.17, 2.8.41, 2.7.48; symfony/security 4.0.11, 3.4.11, 3.3.17, 2.8.41, 2.7.48. A vendor fix does not mean a deployment is fixed. ## Affected components - Packagist symfony/symfony: affected >= 2.7.0, < 2.7.48; >= 2.8.0, < 2.8.41; >= 3.4.0, < 3.4.11; >= 4.0.0, < 4.0.11; >= 3.0.0, < 3.3.17; fixed in 2.7.48, 4.0.11, 2.8.41, 3.3.17, 3.4.11 - Packagist symfony/security-http: affected >= 2.7.0, < 2.7.48; >= 2.8.0, < 2.8.41; >= 3.0.0, < 3.3.17; >= 3.4.0, < 3.4.11; >= 4.0.0, < 4.0.11; fixed in 2.7.48, 4.0.11, 2.8.41, 3.3.17, 3.4.11 - Packagist symfony/security: affected >= 2.7.0, < 2.7.48; >= 2.8.0, < 2.8.41; >= 3.0.0, < 3.3.17; >= 3.4.0, < 3.4.11; >= 4.0.0, < 4.0.11; fixed in 2.7.48, 4.0.11, 2.8.41, 3.3.17, 3.4.11 ## Suggested inspection (read-only) - Packagist symfony/symfony: check the installed version with your package manager. - Packagist symfony/security-http: check the installed version with your package manager. - Packagist symfony/security: check the installed version with your package manager. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on symfony/symfony, symfony/security-http, symfony/security. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-g4rg-rw65-8hfg (GitHub-reviewed advisory GHSA-g4rg-rw65-8hfg lists affected ranges: Packagist symfony/symfony >=2.7.0 =2.8.0 =3.4.0 =4.0.0 =3.0.0 =2.7.0 =2.8.0 =3.0.0 =3.4.0 =4.0.0 =2.7.0 =2.8.0 =3.0.0 =3.4.0 =4.0.0 <4.0.11) Commands are suggestions: review each one before running it.
Loading voting…