Moderate severity vulnerability that affects com.rabbitmq:amqp-client and org.springframework.amqp:spring-amqp
CVE-2018-11087GHSA-w4g2-9hj6-5472
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (org.springframework.amqp:spring-amqp 2.0.6, 1.7.10; com.rabbitmq:amqp-client 5.4.0, 4.8.0), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
Maven org.springframework.amqp:spring-amqp
- Affected
- >= 2.0.0, < 2.0.6< 1.7.10
- Fixed in
- 2.0.6, 1.7.10
Maven com.rabbitmq:amqp-client
- Affected
- < 4.8.0>= 5.0.0, < 5.4.0
- Fixed in
- 4.8.0, 5.4.0
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-w4g2-9hj6-5472 lists affected ranges: Maven org.springframework.amqp:spring-amqp >=2.0.0 =0 =0 =5.0.0 <5.4.0
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 5.9 · CVSS:3.0/AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:N/A:N
- EPSS
- CVE-2018-11087: 1.23% estimated exploitation activity in the next 30 days; percentile 69.07 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Pivotal Spring AMQP, 1.x versions prior to 1.7.10 and 2.x versions prior to 2.0.6, expose a man-in-the-middle vulnerability due to lack of hostname validation. A malicious user that has the ability to intercept traffic would be able to view data in transit.
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 1 · created ·
Published from ghsa record GHSA-w4g2-9hj6-5472
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2018-11087 Advisory: Moderate severity vulnerability that affects com.rabbitmq:amqp-client and org.springframework.amqp:spring-amqp IDs: CVE-2018-11087, GHSA-w4g2-9hj6-5472 Record: https://patchnext.com/advisories/cve-2018-11087 (revision 1, source checked 26 Oct 2026, 15:53 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Medium (CVSS 5.9) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: org.springframework.amqp:spring-amqp 2.0.6, 1.7.10; com.rabbitmq:amqp-client 5.4.0, 4.8.0. A vendor fix does not mean a deployment is fixed. ## Affected components - Maven org.springframework.amqp:spring-amqp: affected >= 2.0.0, < 2.0.6; < 1.7.10; fixed in 2.0.6, 1.7.10 - Maven com.rabbitmq:amqp-client: affected < 4.8.0; >= 5.0.0, < 5.4.0; fixed in 4.8.0, 5.4.0 ## Suggested inspection (read-only) - Maven org.springframework.amqp:spring-amqp: check the installed version with your package manager. - Maven com.rabbitmq:amqp-client: check the installed version with your package manager. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on org.springframework.amqp:spring-amqp, com.rabbitmq:amqp-client. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-w4g2-9hj6-5472 (GitHub-reviewed advisory GHSA-w4g2-9hj6-5472 lists affected ranges: Maven org.springframework.amqp:spring-amqp >=2.0.0 =0 =0 =5.0.0 <5.4.0) Commands are suggestions: review each one before running it.
Loading voting…