Cloud Foundry UAA accepts refresh token as access token on admin endpoints
CVE-2018-11047GHSA-r4v8-9hgx-vm6m
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (org.cloudfoundry.identity:cloudfoundry-identity-server 4.19.2, 4.12.4, 4.10.2, 4.7.6, 4.5.7), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
Maven org.cloudfoundry.identity:cloudfoundry-identity-server
- Affected
- < 4.5.7>= 4.6.0, < 4.7.6>= 4.8.0, < 4.10.2>= 4.11.0, < 4.12.4>= 4.13.0, < 4.19.2
- Fixed in
- 4.10.2, 4.12.4, 4.5.7, 4.19.2, 4.7.6
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-r4v8-9hgx-vm6m lists affected ranges: Maven org.cloudfoundry.identity:cloudfoundry-identity-server >=0 =4.6.0 =4.8.0 =4.11.0 =4.13.0 <4.19.2
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 7.5 · CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:H/A:N
- EPSS
- CVE-2018-11047: 1.07% estimated exploitation activity in the next 30 days; percentile 64.81 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Cloud Foundry UAA, versions 4.19 prior to 4.19.2 and 4.12 prior to 4.12.4 and 4.10 prior to 4.10.2 and 4.7 prior to 4.7.6 and 4.5 prior to 4.5.7, incorrectly authorizes requests to admin endpoints by accepting a valid refresh token in lieu of an access token. Refresh tokens by design have a longer expiration time than access tokens, allowing the possessor of a refresh token to authenticate longer than expected. This affects the administrative endpoints of the UAA. i.e. /Users, /Groups, etc. However, if the user has been deleted or had groups removed, or the client was deleted, the refresh token will no longer be valid.
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 1 · created ·
Published from ghsa record GHSA-r4v8-9hgx-vm6m
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2018-11047 Advisory: Cloud Foundry UAA accepts refresh token as access token on admin endpoints IDs: CVE-2018-11047, GHSA-r4v8-9hgx-vm6m Record: https://patchnext.com/advisories/cve-2018-11047 (revision 1, source checked 26 Oct 2026, 16:26 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: High (CVSS 7.5) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: org.cloudfoundry.identity:cloudfoundry-identity-server 4.19.2, 4.12.4, 4.10.2, 4.7.6, 4.5.7. A vendor fix does not mean a deployment is fixed. ## Affected components - Maven org.cloudfoundry.identity:cloudfoundry-identity-server: affected < 4.5.7; >= 4.6.0, < 4.7.6; >= 4.8.0, < 4.10.2; >= 4.11.0, < 4.12.4; >= 4.13.0, < 4.19.2; fixed in 4.10.2, 4.12.4, 4.5.7, 4.19.2, 4.7.6 ## Suggested inspection (read-only) - Maven org.cloudfoundry.identity:cloudfoundry-identity-server: check the installed version with your package manager. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on org.cloudfoundry.identity:cloudfoundry-identity-server. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-r4v8-9hgx-vm6m (GitHub-reviewed advisory GHSA-r4v8-9hgx-vm6m lists affected ranges: Maven org.cloudfoundry.identity:cloudfoundry-identity-server >=0 =4.6.0 =4.8.0 =4.11.0 =4.13.0 <4.19.2) Commands are suggestions: review each one before running it.
Loading voting…