Skip to content

← Actionable
Medium, CVSS 6.1

Cloud Foundry UAA open redirect

CVE-2018-11041GHSA-xh4m-99qp-w483

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (org.cloudfoundry.identity:cloudfoundry-identity-server 4.19.0, 4.12.3, 4.10.1, 4.7.5), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

Sources

  • GitHub Advisory Database and maintainer security advisories on GitHub

    GitHub-reviewed advisory GHSA-xh4m-99qp-w483 lists affected ranges: Maven org.cloudfoundry.identity:cloudfoundry-identity-server >=0 =4.8.0 =4.11.0 =4.13.0 <4.19.0

    VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
6.1 · CVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N
EPSS
  • CVE-2018-11041: 0.84% estimated exploitation activity in the next 30 days; percentile 57.81 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Cloud Foundry UAA, versions later than 4.6.0 and prior to 4.19.0 except 4.10.1 and 4.7.5 and uaa-release versions later than v48 and prior to v60 except v55.1 and v52.9, does not validate redirect URL values on a form parameter used for internal UAA redirects on the login page, allowing open redirects. A remote attacker can craft a malicious link that, when clicked, will redirect users to arbitrary websites after a successful login attempt.

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 1 · created ·

    Published from ghsa record GHSA-xh4m-99qp-w483

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2018-11041

Advisory: Cloud Foundry UAA open redirect
IDs: CVE-2018-11041, GHSA-xh4m-99qp-w483
Record: https://patchnext.com/advisories/cve-2018-11041 (revision 1, source checked 26 Oct 2026, 16:26 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Medium (CVSS 6.1)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: org.cloudfoundry.identity:cloudfoundry-identity-server 4.19.0, 4.12.3, 4.10.1, 4.7.5. A vendor fix does not mean a deployment is fixed.

## Affected components
- Maven org.cloudfoundry.identity:cloudfoundry-identity-server: affected < 4.7.5; >= 4.8.0, < 4.10.1; >= 4.11.0, < 4.12.3; >= 4.13.0, < 4.19.0; fixed in 4.19.0, 4.7.5, 4.12.3, 4.10.1

## Suggested inspection (read-only)
- Maven org.cloudfoundry.identity:cloudfoundry-identity-server: check the installed version with your package manager.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on org.cloudfoundry.identity:cloudfoundry-identity-server.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-xh4m-99qp-w483 (GitHub-reviewed advisory GHSA-xh4m-99qp-w483 lists affected ranges: Maven org.cloudfoundry.identity:cloudfoundry-identity-server >=0 =4.8.0 =4.11.0 =4.13.0 <4.19.0)

Commands are suggestions: review each one before running it.

Loading voting…