Skip to content

← Actionable
High, CVSS 8.7amended

PyCA Cryptography vulnerable to GCM tag forgery

CVE-2018-10903GHSA-fcf9-3qw3-gxmj

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (cryptography 2.3), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS 4.0
8.7 · CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:H/VI:N/VA:N/SC:N/SI:N/SA:N · score source
EPSS
  • CVE-2018-10903: 3.20% estimated exploitation activity in the next 30 days; percentile 88.13 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

A flaw was found in python-cryptography versions between =1.9.0 and <2.3. The finalizewithtag API did not enforce a minimum tag length. If a user did not validate the input length prior to passing it to finalizewithtag an attacker could craft an invalid payload with a shortened tag (e.g. 1 byte) such that they would have a 1 in 256 chance of passing the MAC check. GCM tag forgeries can cause key leakage.

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 3 · amended ·

    Amended from ghsa record GHSA-fcf9-3qw3-gxmj

  2. Revision 2 · amended ·

    Reviewed OSV alias/range/CVSS4 correction; package source scopes and original publication preserved. No customer finding resolved.

  3. Revision 1 · created ·

    Published from osv record GHSA-fcf9-3qw3-gxmj

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2018-10903

Advisory: PyCA Cryptography vulnerable to GCM tag forgery
IDs: CVE-2018-10903, GHSA-fcf9-3qw3-gxmj
Record: https://patchnext.com/advisories/cve-2018-10903 (revision 3, source checked 26 Oct 2026, 13:17 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: High (CVSS 8.7)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: cryptography 2.3. A vendor fix does not mean a deployment is fixed.

## Affected components
- PyPI cryptography: affected >= 1.9.0, < 2.3; fixed in 2.3

## Suggested inspection (read-only)
- `python -m pip show cryptography`: prints the installed version. Run with the environment that serves production active.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on cryptography.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/GHSA-fcf9-3qw3-gxmj (OSV record GHSA-fcf9-3qw3-gxmj lists affected ranges: PyPI cryptography >=1.9.0 <2.3 (fixed))
- Verified: https://github.com/advisories/GHSA-fcf9-3qw3-gxmj (GitHub-reviewed advisory GHSA-fcf9-3qw3-gxmj lists affected ranges: PyPI cryptography >=1.9.0 <2.3)

Commands are suggestions: review each one before running it.

Loading voting…