Skip to content

← Actionable
High, CVSS 7.5amended

Matrix Synapse DoS

CVE-2018-10657GHSA-vmcc-4p4x-x7wg

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (matrix-synapse 0.28.1), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
7.5 · CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H
EPSS
  • CVE-2018-10657: 1.49% estimated exploitation activity in the next 30 days; percentile 74.18 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Matrix Synapse before 0.28.1 is prone to a denial of service flaw where malicious events injected with depth = 2<sup63</sup - 1 render rooms unusable, related to federation/federationbase.py and handlers/message.py, as exploited in the wild in April 2018.

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 2 · amended ·

    Amended from ghsa record GHSA-vmcc-4p4x-x7wg

  2. Revision 1 · created ·

    Published from osv record GHSA-vmcc-4p4x-x7wg

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2018-10657

Advisory: Matrix Synapse DoS
IDs: CVE-2018-10657, GHSA-vmcc-4p4x-x7wg
Record: https://patchnext.com/advisories/cve-2018-10657 (revision 2, source checked 26 Oct 2026, 13:12 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: High (CVSS 7.5)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: matrix-synapse 0.28.1. A vendor fix does not mean a deployment is fixed.

## Affected components
- PyPI matrix-synapse: affected < 0.28.1; fixed in 0.28.1

## Suggested inspection (read-only)
- `python -m pip show matrix-synapse`: prints the installed version. Run with the environment that serves production active.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on matrix-synapse.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/GHSA-vmcc-4p4x-x7wg (OSV record GHSA-vmcc-4p4x-x7wg lists affected ranges: PyPI matrix-synapse >=0 <0.28.1 (fixed))
- Verified: https://github.com/advisories/GHSA-vmcc-4p4x-x7wg (GitHub-reviewed advisory GHSA-vmcc-4p4x-x7wg lists affected ranges: PyPI matrix-synapse >=0 <0.28.1)

Commands are suggestions: review each one before running it.

Loading voting…