Moodle XSS Vulnerability
CVE-2018-1045GHSA-595j-wpfg-23w4
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (moodle/moodle 3.3.4, 3.2.7, 3.1.10), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
Packagist moodle/moodle
- Affected
- >= 3.3, <= 3.3.3>= 3.2, <= 3.2.6>= 3.1, <= 3.1.9
- Fixed in
- 3.2.7, 3.1.10, 3.3.4
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-595j-wpfg-23w4 lists affected ranges: Packagist moodle/moodle >=3.3 =3.2 =3.1 <=3.1.9
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 5.4 · CVSS:3.0/AV:N/AC:L/PR:L/UI:R/S:C/C:L/I:L/A:N
- EPSS
- CVE-2018-1045: 0.97% estimated exploitation activity in the next 30 days; percentile 61.79 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
In Moodle 3.x, there is XSS via a calendar event name.
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 1 · created ·
Published from ghsa record GHSA-595j-wpfg-23w4
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2018-1045 Advisory: Moodle XSS Vulnerability IDs: CVE-2018-1045, GHSA-595j-wpfg-23w4 Record: https://patchnext.com/advisories/cve-2018-1045 (revision 1, source checked 26 Oct 2026, 14:06 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Medium (CVSS 5.4) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: moodle/moodle 3.3.4, 3.2.7, 3.1.10. A vendor fix does not mean a deployment is fixed. ## Affected components - Packagist moodle/moodle: affected >= 3.3, <= 3.3.3; >= 3.2, <= 3.2.6; >= 3.1, <= 3.1.9; fixed in 3.2.7, 3.1.10, 3.3.4 ## Suggested inspection (read-only) - Packagist moodle/moodle: check the installed version with your package manager. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on moodle/moodle. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-595j-wpfg-23w4 (GitHub-reviewed advisory GHSA-595j-wpfg-23w4 lists affected ranges: Packagist moodle/moodle >=3.3 =3.2 =3.1 <=3.1.9) Commands are suggestions: review each one before running it.
Loading voting…