Skip to content

← Actionable
Medium, CVSS 5.9

Denial of Service in Google Guava

CVE-2018-10237GHSA-mvr2-9pj6-7w5j

What to do

Partial vendor fix. Follow the primary source's mitigation guidance and check back for a fix.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • Maven org.hudsonci.lib.guava:guava

    Affected
    <= 14.0.1-h-3
    Fixed in
    no fixed version recorded
  • Maven com.google.guava:guava

    Affected
    >= 11.0, < 24.1.1-android
    Fixed in
    24.1.1-android
  • Maven com.googlecode.guava-osgi:guava-osgi

    Affected
    <= 11.0.1
    Fixed in
    no fixed version recorded
  • Maven de.mhus.ports:vaadin-shared-deps

    Affected
    <= 7.4.0
    Fixed in
    no fixed version recorded
  • Maven com.google.guava:guava-jdk5

    Affected
    <= 17.0
    Fixed in
    no fixed version recorded
  • Maven org.sonatype.sisu:sisu-guava

    Affected
    >= 0.11.1, <= 0.11.1
    Fixed in
    no fixed version recorded

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
5.9 · CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:N/I:N/A:H
EPSS
  • CVE-2018-10237: 5.09% estimated exploitation activity in the next 30 days; percentile 92.36 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Unbounded memory allocation in Google Guava 11.0 through 24.x before 24.1.1 allows remote attackers to conduct denial of service attacks against servers that depend on this library and deserialize attacker-provided data, because the AtomicDoubleArray class (when serialized with Java serialization) and the CompoundOrdering class (when serialized with GWT serialization) perform eager allocation without appropriate checks on what a client has sent and whether the data size is reasonable.

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 1 · created ·

    Published from ghsa record GHSA-mvr2-9pj6-7w5j

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2018-10237

Advisory: Denial of Service in Google Guava
IDs: CVE-2018-10237, GHSA-mvr2-9pj6-7w5j
Record: https://patchnext.com/advisories/cve-2018-10237 (revision 1, source checked 26 Oct 2026, 16:16 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Medium (CVSS 5.9)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Partial vendor fix; fixed versions by package: com.google.guava:guava 24.1.1-android. A vendor fix does not mean a deployment is fixed.

## Affected components
- Maven org.hudsonci.lib.guava:guava: affected <= 14.0.1-h-3
- Maven com.google.guava:guava: affected >= 11.0, < 24.1.1-android; fixed in 24.1.1-android
- Maven com.googlecode.guava-osgi:guava-osgi: affected <= 11.0.1
- Maven de.mhus.ports:vaadin-shared-deps: affected <= 7.4.0
- Maven com.google.guava:guava-jdk5: affected <= 17.0
- Maven org.sonatype.sisu:sisu-guava: affected >= 0.11.1, <= 0.11.1

## Suggested inspection (read-only)
- Maven org.hudsonci.lib.guava:guava: check the installed version with your package manager.
- Maven com.google.guava:guava: check the installed version with your package manager.
- Maven com.googlecode.guava-osgi:guava-osgi: check the installed version with your package manager.
- Maven de.mhus.ports:vaadin-shared-deps: check the installed version with your package manager.
- Maven com.google.guava:guava-jdk5: check the installed version with your package manager.
- Maven org.sonatype.sisu:sisu-guava: check the installed version with your package manager.

## Supported action
No complete vendor fix is recorded. Follow the primary source's mitigation guidance and check this record again before closing anything.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on org.hudsonci.lib.guava:guava, com.google.guava:guava, com.googlecode.guava-osgi:guava-osgi, de.mhus.ports:vaadin-shared-deps, com.google.guava:guava-jdk5, org.sonatype.sisu:sisu-guava.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-mvr2-9pj6-7w5j (GitHub-reviewed advisory GHSA-mvr2-9pj6-7w5j lists affected ranges: Maven com.google.guava:guava-jdk5 >=0 =0 =0 =0 =0.11.1 =11.0 <24.1.1-android)

Commands are suggestions: review each one before running it.

Loading voting…