Skip to content

← Actionable
Medium, CVSS 5.5amended

Arbitrary File Write in adm-zip

CVE-2018-1002204GHSA-3v6h-hqm4-2rg6

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (adm-zip 0.4.11), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • npm adm-zip

    Affected
    < 0.4.11
    Fixed in
    0.4.11

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
5.5 · CVSS:3.1/AV:L/AC:L/PR:N/UI:R/S:U/C:N/I:H/A:N
EPSS
  • CVE-2018-1002204: 13.45% estimated exploitation activity in the next 30 days; percentile 96.44 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Versions of adm-zip before 0.4.9 are vulnerable to arbitrary file write when used to extract a specifically crafted archive that contains path traversal filenames (../../file.txt for example). Recommendation Update to version 0.4.9 or later.

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 2 · amended ·

    Amended from ghsa record GHSA-3v6h-hqm4-2rg6

  2. Revision 1 · created ·

    Published from osv record GHSA-3v6h-hqm4-2rg6

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2018-1002204

Advisory: Arbitrary File Write in adm-zip
IDs: CVE-2018-1002204, GHSA-3v6h-hqm4-2rg6
Record: https://patchnext.com/advisories/cve-2018-1002204 (revision 2, source checked 26 Oct 2026, 12:26 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Medium (CVSS 5.5)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: adm-zip 0.4.11. A vendor fix does not mean a deployment is fixed.

## Affected components
- npm adm-zip: affected < 0.4.11; fixed in 0.4.11

## Suggested inspection (read-only)
- `npm ls adm-zip --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on adm-zip.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/GHSA-3v6h-hqm4-2rg6 (OSV record GHSA-3v6h-hqm4-2rg6 lists affected ranges: npm adm-zip >=0 <0.4.11 (fixed))
- Verified: https://github.com/advisories/GHSA-3v6h-hqm4-2rg6 (GitHub-reviewed advisory GHSA-3v6h-hqm4-2rg6 lists affected ranges: npm adm-zip >=0 <0.4.11)

Commands are suggestions: review each one before running it.

Loading voting…