Privilege Escalation in Kubernetes
CVE-2018-1002105GHSA-579h-mv94-g4gp
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (github.com/kubernetes/kubernetes 1.12.3, 1.11.5, 1.10.11), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
Go github.com/kubernetes/kubernetes
- Affected
- < 1.10.11>= 1.11.0, < 1.11.5>= 1.12.0, < 1.12.3
- Fixed in
- 1.12.3, 1.11.5, 1.10.11
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-579h-mv94-g4gp lists affected ranges: Go github.com/kubernetes/kubernetes >=0 =1.11.0 =1.12.0 <1.12.3
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 9.8 · CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
- EPSS
- CVE-2018-1002105: 86.98% estimated exploitation activity in the next 30 days; percentile 99.75 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
In all Kubernetes versions prior to v1.10.11, v1.11.5, and v1.12.3, incorrect handling of error responses to proxied upgrade requests in the kube-apiserver allowed specially crafted requests to establish a connection through the Kubernetes API server to backend servers, then send arbitrary requests over the same connection directly to the backend, authenticated with the Kubernetes API server's TLS credentials used to establish the backend connection.
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 1 · created ·
Published from ghsa record GHSA-579h-mv94-g4gp
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2018-1002105 Advisory: Privilege Escalation in Kubernetes IDs: CVE-2018-1002105, GHSA-579h-mv94-g4gp Record: https://patchnext.com/advisories/cve-2018-1002105 (revision 1, source checked 26 Oct 2026, 14:54 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Critical (CVSS 9.8) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: github.com/kubernetes/kubernetes 1.12.3, 1.11.5, 1.10.11. A vendor fix does not mean a deployment is fixed. ## Affected components - Go github.com/kubernetes/kubernetes: affected < 1.10.11; >= 1.11.0, < 1.11.5; >= 1.12.0, < 1.12.3; fixed in 1.12.3, 1.11.5, 1.10.11 ## Suggested inspection (read-only) - Go github.com/kubernetes/kubernetes: check the installed version with your package manager. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on github.com/kubernetes/kubernetes. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-579h-mv94-g4gp (GitHub-reviewed advisory GHSA-579h-mv94-g4gp lists affected ranges: Go github.com/kubernetes/kubernetes >=0 =1.11.0 =1.12.0 <1.12.3) Commands are suggestions: review each one before running it.
Loading voting…