Loop with Unreachable Exit Condition in Jenkins
CVE-2018-1000864GHSA-9cjv-93g7-c6mv
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (org.jenkins-ci.main:jenkins-core 2.154, 2.138.4), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
Maven org.jenkins-ci.main:jenkins-core
- Affected
- <= 2.138.3>= 2.140, <= 2.153
- Fixed in
- 2.138.4, 2.154
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-9cjv-93g7-c6mv lists affected ranges: Maven org.jenkins-ci.main:jenkins-core >=0 =2.140 <=2.153
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 6.5 · CVSS:3.0/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:N/A:H
- EPSS
- CVE-2018-1000864: 2.75% estimated exploitation activity in the next 30 days; percentile 86.23 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
A denial of service vulnerability exists in Jenkins 2.153 and earlier, LTS 2.138.3 and earlier in CronTab.java that allows attackers with Overall/Read permission to have a request handling thread enter an infinite loop.
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 1 · created ·
Published from ghsa record GHSA-9cjv-93g7-c6mv
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2018-1000864 Advisory: Loop with Unreachable Exit Condition in Jenkins IDs: CVE-2018-1000864, GHSA-9cjv-93g7-c6mv Record: https://patchnext.com/advisories/cve-2018-1000864 (revision 1, source checked 26 Oct 2026, 16:21 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Medium (CVSS 6.5) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: org.jenkins-ci.main:jenkins-core 2.154, 2.138.4. A vendor fix does not mean a deployment is fixed. ## Affected components - Maven org.jenkins-ci.main:jenkins-core: affected <= 2.138.3; >= 2.140, <= 2.153; fixed in 2.138.4, 2.154 ## Suggested inspection (read-only) - Maven org.jenkins-ci.main:jenkins-core: check the installed version with your package manager. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on org.jenkins-ci.main:jenkins-core. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-9cjv-93g7-c6mv (GitHub-reviewed advisory GHSA-9cjv-93g7-c6mv lists affected ranges: Maven org.jenkins-ci.main:jenkins-core >=0 =2.140 <=2.153) Commands are suggestions: review each one before running it.
Loading voting…