aiohttp-session creates non-expiring sessions
CVE-2018-1000814GHSA-mr4x-c4v9-x729
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (aiohttp-session 2.7.0), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
PyPI aiohttp-session
- Affected
- <= 2.6.0
- Fixed in
- 2.7.0
Sources
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-mr4x-c4v9-x729 lists affected ranges: PyPI aiohttp-session >=0 <2.7.0 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-mr4x-c4v9-x729 lists affected ranges: PyPI aiohttp-session >=0 <=2.6.0
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS 4.0
- 7.1 · CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:N/VC:N/VI:H/VA:N/SC:N/SI:N/SA:N · score source
- EPSS
- CVE-2018-1000814: 0.97% estimated exploitation activity in the next 30 days; percentile 61.74 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
aio-libs aiohttp-session version 2.6.0 and earlier contains a Other/Unknown vulnerability in EncryptedCookieStorage and NaClCookieStorage that can result in Non-expiring sessions / Infinite lifespan. This attack appear to be exploitable via Recreation of a cookie post-expiry with the same value.
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 3 · amended ·
Amended from ghsa record GHSA-mr4x-c4v9-x729
- Revision 2 · amended ·
Reviewed OSV alias/range/CVSS4 correction; package source scopes and original publication preserved. No customer finding resolved.
- Revision 1 · created ·
Published from osv record GHSA-mr4x-c4v9-x729
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2018-1000814 Advisory: aiohttp-session creates non-expiring sessions IDs: CVE-2018-1000814, GHSA-mr4x-c4v9-x729 Record: https://patchnext.com/advisories/cve-2018-1000814 (revision 3, source checked 26 Oct 2026, 13:31 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: High (CVSS 7.1) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: aiohttp-session 2.7.0. A vendor fix does not mean a deployment is fixed. ## Affected components - PyPI aiohttp-session: affected <= 2.6.0; fixed in 2.7.0 ## Suggested inspection (read-only) - `python -m pip show aiohttp-session`: prints the installed version. Run with the environment that serves production active. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on aiohttp-session. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://osv.dev/vulnerability/GHSA-mr4x-c4v9-x729 (OSV record GHSA-mr4x-c4v9-x729 lists affected ranges: PyPI aiohttp-session >=0 <2.7.0 (fixed)) - Verified: https://github.com/advisories/GHSA-mr4x-c4v9-x729 (GitHub-reviewed advisory GHSA-mr4x-c4v9-x729 lists affected ranges: PyPI aiohttp-session >=0 <=2.6.0) Commands are suggestions: review each one before running it.
Loading voting…