Deserialization of Untrusted Data in Bouncy castle
CVE-2018-1000613GHSA-4446-656p-f54g
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (org.bouncycastle:bcprov-jdk15on 1.60), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
Maven org.bouncycastle:bcprov-jdk15on
- Affected
- >= 1.57, < 1.60
- Fixed in
- 1.60
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-4446-656p-f54g lists affected ranges: Maven org.bouncycastle:bcprov-jdk15on >=1.57 <1.60
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 9.8 · CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
- EPSS
- CVE-2018-1000613: 4.77% estimated exploitation activity in the next 30 days; percentile 91.92 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Legion of the Bouncy Castle Java Cryptography APIs starting in version 1.57 and prior to version 1.60 contains a CWE-470: Use of Externally-Controlled Input to Select Classes or Code ('Unsafe Reflection') vulnerability in XMSS/XMSS^MT private key deserialization that can result in Deserializing an XMSS/XMSS^MT private key can result in the execution of unexpected code. This attack appear to be exploitable via A handcrafted private key can include references to unexpected classes which will be picked up from the class path for the executing application. This vulnerability appears to have been fixed in 1.60 and later.
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 1 · created ·
Published from ghsa record GHSA-4446-656p-f54g
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2018-1000613 Advisory: Deserialization of Untrusted Data in Bouncy castle IDs: CVE-2018-1000613, GHSA-4446-656p-f54g Record: https://patchnext.com/advisories/cve-2018-1000613 (revision 1, source checked 26 Oct 2026, 16:36 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Critical (CVSS 9.8) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: org.bouncycastle:bcprov-jdk15on 1.60. A vendor fix does not mean a deployment is fixed. ## Affected components - Maven org.bouncycastle:bcprov-jdk15on: affected >= 1.57, < 1.60; fixed in 1.60 ## Suggested inspection (read-only) - Maven org.bouncycastle:bcprov-jdk15on: check the installed version with your package manager. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on org.bouncycastle:bcprov-jdk15on. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-4446-656p-f54g (GitHub-reviewed advisory GHSA-4446-656p-f54g lists affected ranges: Maven org.bouncycastle:bcprov-jdk15on >=1.57 <1.60) Commands are suggestions: review each one before running it.
Loading voting…