URLTrigger Plugin server-side request forgery vulnerability
CVE-2018-1000606GHSA-rv87-vcv4-fjvr
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (org.jenkins-ci.plugins:urltrigger 0.43), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
Maven org.jenkins-ci.plugins:urltrigger
- Affected
- <= 0.41
- Fixed in
- 0.43
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-rv87-vcv4-fjvr lists affected ranges: Maven org.jenkins-ci.plugins:urltrigger >=0 <=0.41
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 6.5 · CVSS:3.0/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:H/A:N
- EPSS
- CVE-2018-1000606: 0.70% estimated exploitation activity in the next 30 days; percentile 53.21 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
A server-side request forgery vulnerability exists in Jenkins URLTrigger Plugin 0.41 and earlier in URLTrigger.java that allows attackers with Overall/Read access to cause Jenkins to send a GET request to a specified URL. As of version 0.43, this form validation method no longer connects to a user provided URL.
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 1 · created ·
Published from ghsa record GHSA-rv87-vcv4-fjvr
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2018-1000606 Advisory: URLTrigger Plugin server-side request forgery vulnerability IDs: CVE-2018-1000606, GHSA-rv87-vcv4-fjvr Record: https://patchnext.com/advisories/cve-2018-1000606 (revision 1, source checked 26 Oct 2026, 16:00 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Medium (CVSS 6.5) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: org.jenkins-ci.plugins:urltrigger 0.43. A vendor fix does not mean a deployment is fixed. ## Affected components - Maven org.jenkins-ci.plugins:urltrigger: affected <= 0.41; fixed in 0.43 ## Suggested inspection (read-only) - Maven org.jenkins-ci.plugins:urltrigger: check the installed version with your package manager. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on org.jenkins-ci.plugins:urltrigger. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-rv87-vcv4-fjvr (GitHub-reviewed advisory GHSA-rv87-vcv4-fjvr lists affected ranges: Maven org.jenkins-ci.plugins:urltrigger >=0 <=0.41) Commands are suggestions: review each one before running it.
Loading voting…