Skip to content

← Actionable
Critical, CVSS 9.8

Rubyzip gem contains a Directory Traversal vulnerability in zip file component

CVE-2018-1000544GHSA-vqcq-mrmw-mcmg

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (rubyzip 1.2.2), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • RubyGems rubyzip

    Affected
    <= 1.2.1
    Fixed in
    1.2.2

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
9.8 · CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
EPSS
  • CVE-2018-1000544: 4.34% estimated exploitation activity in the next 30 days; percentile 91.22 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

rubyzip gem rubyzip version 1.2.1 and earlier contains a Directory Traversal vulnerability in Zip::File component that can result in write arbitrary files to the filesystem. This attack appear to be exploitable via If a site allows uploading of .zip files , an attacker can upload a malicious file that contains symlinks or files with absolute pathnames "../" to write arbitrary files to the filesystem.. This is similar to CVE-2017-5946 which was patched in 1.2.1 but the fix in that case was incomplete.

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 1 · created ·

    Published from ghsa record GHSA-vqcq-mrmw-mcmg

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2018-1000544

Advisory: Rubyzip gem contains a Directory Traversal vulnerability in zip file component
IDs: CVE-2018-1000544, GHSA-vqcq-mrmw-mcmg
Record: https://patchnext.com/advisories/cve-2018-1000544 (revision 1, source checked 26 Oct 2026, 15:47 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Critical (CVSS 9.8)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: rubyzip 1.2.2. A vendor fix does not mean a deployment is fixed.

## Affected components
- RubyGems rubyzip: affected <= 1.2.1; fixed in 1.2.2

## Suggested inspection (read-only)
- RubyGems rubyzip: check the installed version with your package manager.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on rubyzip.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-vqcq-mrmw-mcmg (GitHub-reviewed advisory GHSA-vqcq-mrmw-mcmg lists affected ranges: RubyGems rubyzip >=0 <=1.2.1)

Commands are suggestions: review each one before running it.

Loading voting…