Skip to content

← Actionable
Medium, CVSS 6.1amended

Joplin Vulnerable to Cross-site Scripting in Note Content

CVE-2018-1000534GHSA-m6mf-hmrh-ph4j

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (joplin 1.0.90), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • npm joplin

    Affected
    < 1.0.90
    Fixed in
    1.0.90

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
6.1 · CVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N
EPSS
  • CVE-2018-1000534: 1.50% estimated exploitation activity in the next 30 days; percentile 74.39 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Joplin version prior to 1.0.90 contains a Cross-site Scripting (XSS) evolving into code execution due to enabled nodeIntegration for that particular BrowserWindow instance where XSS was identified from vulnerability in Note content field - information on the fix can be found here https://github.com/laurent22/joplin/commit/494e235e18659574f836f84fcf9f4d4fcdcfcf89 that can result in executing unauthorized code within the rights in which the application is running. This attack appear to be exploitable via Victim synchronizing notes from the cloud services or other note-keeping services which contain malicious code. This vulnerability appears to have been fixed in 1.0.90 and later.

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 2 · amended ·

    Amended from ghsa record GHSA-m6mf-hmrh-ph4j

  2. Revision 1 · created ·

    Published from osv record GHSA-m6mf-hmrh-ph4j

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2018-1000534

Advisory: Joplin Vulnerable to Cross-site Scripting in Note Content
IDs: CVE-2018-1000534, GHSA-m6mf-hmrh-ph4j
Record: https://patchnext.com/advisories/cve-2018-1000534 (revision 2, source checked 26 Oct 2026, 12:30 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Medium (CVSS 6.1)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: joplin 1.0.90. A vendor fix does not mean a deployment is fixed.

## Affected components
- npm joplin: affected < 1.0.90; fixed in 1.0.90

## Suggested inspection (read-only)
- `npm ls joplin --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on joplin.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/GHSA-m6mf-hmrh-ph4j (OSV record GHSA-m6mf-hmrh-ph4j lists affected ranges: npm joplin >=0 <1.0.90 (fixed))
- Verified: https://github.com/advisories/GHSA-m6mf-hmrh-ph4j (GitHub-reviewed advisory GHSA-m6mf-hmrh-ph4j lists affected ranges: npm joplin >=0 <1.0.90)

Commands are suggestions: review each one before running it.

Loading voting…