Jenkins Job Config History Plugin reflected XSS vulnerability
CVE-2018-1000416GHSA-w3r4-vx9w-f7p7
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (org.jenkins-ci.plugins:jobConfigHistory 2.18.1), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
Maven org.jenkins-ci.plugins:jobConfigHistory
- Affected
- <= 2.18
- Fixed in
- 2.18.1
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-w3r4-vx9w-f7p7 lists affected ranges: Maven org.jenkins-ci.plugins:jobConfigHistory >=0 <=2.18
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 6.1 · CVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N
- EPSS
- CVE-2018-1000416: 0.84% estimated exploitation activity in the next 30 days; percentile 57.97 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
A reflected cross-site scripting vulnerability exists in Jenkins Job Config History Plugin 2.18 and earlier in all Jelly files that shows arbitrary attacker-specified HTML in Jenkins to users with Job/Configure access.
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 1 · created ·
Published from ghsa record GHSA-w3r4-vx9w-f7p7
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2018-1000416 Advisory: Jenkins Job Config History Plugin reflected XSS vulnerability IDs: CVE-2018-1000416, GHSA-w3r4-vx9w-f7p7 Record: https://patchnext.com/advisories/cve-2018-1000416 (revision 1, source checked 26 Oct 2026, 16:25 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Medium (CVSS 6.1) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: org.jenkins-ci.plugins:jobConfigHistory 2.18.1. A vendor fix does not mean a deployment is fixed. ## Affected components - Maven org.jenkins-ci.plugins:jobConfigHistory: affected <= 2.18; fixed in 2.18.1 ## Suggested inspection (read-only) - Maven org.jenkins-ci.plugins:jobConfigHistory: check the installed version with your package manager. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on org.jenkins-ci.plugins:jobConfigHistory. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-w3r4-vx9w-f7p7 (GitHub-reviewed advisory GHSA-w3r4-vx9w-f7p7 lists affected ranges: Maven org.jenkins-ci.plugins:jobConfigHistory >=0 <=2.18) Commands are suggestions: review each one before running it.
Loading voting…