Skip to content

← Actionable
High, CVSS 7.8

High severity vulnerability that affects YamlDotNet and YamlDotNet.Signed

CVE-2018-1000210GHSA-rpch-cqj9-h65r

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (yamldotnet.signed 5.0.0; yamldotnet 5.0.0), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
7.8 · CVSS:3.0/AV:L/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H
EPSS
  • CVE-2018-1000210: 1.47% estimated exploitation activity in the next 30 days; percentile 73.77 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

YamlDotNet version 4.3.2 and earlier contains a Insecure Direct Object Reference vulnerability in The default behavior of Deserializer.Deserialize() will deserialize user-controlled types in the line "currentType = Type.GetType(nodeEvent.Tag.Substring(1), throwOnError: false);" and blindly instantiates them. that can result in Code execution in the context of the running process. This attack appear to be exploitable via Victim must parse a specially-crafted YAML file. This vulnerability appears to have been fixed in 5.0.0.

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 1 · created ·

    Published from ghsa record GHSA-rpch-cqj9-h65r

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2018-1000210

Advisory: High severity vulnerability that affects YamlDotNet and YamlDotNet.Signed
IDs: CVE-2018-1000210, GHSA-rpch-cqj9-h65r
Record: https://patchnext.com/advisories/cve-2018-1000210 (revision 1, source checked 26 Oct 2026, 16:58 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: High (CVSS 7.8)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: yamldotnet.signed 5.0.0; yamldotnet 5.0.0. A vendor fix does not mean a deployment is fixed.

## Affected components
- NuGet yamldotnet.signed: affected <= 4.3.2; fixed in 5.0.0
- NuGet yamldotnet: affected <= 4.3.2; fixed in 5.0.0

## Suggested inspection (read-only)
- NuGet yamldotnet.signed: check the installed version with your package manager.
- NuGet yamldotnet: check the installed version with your package manager.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on yamldotnet.signed, yamldotnet.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-rpch-cqj9-h65r (GitHub-reviewed advisory GHSA-rpch-cqj9-h65r lists affected ranges: NuGet yamldotnet >=0 =0 <=4.3.2)

Commands are suggestions: review each one before running it.

Loading voting…