Skip to content

← Actionable
Medium, CVSS 6.5

Jenkins Black Duck Detect Plugin information exposure vulnerability

CVE-2018-1000191GHSA-6w3h-vq7m-v3qf

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (com.synopsys.integration:synopsys-detect 1.4.1), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
6.5 · CVSS:3.0/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:N/A:N
EPSS
  • CVE-2018-1000191: 0.99% estimated exploitation activity in the next 30 days; percentile 62.53 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Jenkins Black Duck Detect Plugin did not perform permission checks on methods implementing form validation. This allowed users with Overall/Read access to Jenkins to connect to an attacker-specified URL using attacker-specified credentials IDs obtained through another method, capturing credentials stored in Jenkins, and to cause Jenkins to submit HTTP requests to attacker-specified URLs. Additionally, these form validation methods did not require POST requests, resulting in a CSRF vulnerability. These form validation methods now require POST requests and Overall/Administer permissions.

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 1 · created ·

    Published from ghsa record GHSA-6w3h-vq7m-v3qf

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2018-1000191

Advisory: Jenkins Black Duck Detect Plugin information exposure vulnerability
IDs: CVE-2018-1000191, GHSA-6w3h-vq7m-v3qf
Record: https://patchnext.com/advisories/cve-2018-1000191 (revision 1, source checked 26 Oct 2026, 16:25 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Medium (CVSS 6.5)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: com.synopsys.integration:synopsys-detect 1.4.1. A vendor fix does not mean a deployment is fixed.

## Affected components
- Maven com.synopsys.integration:synopsys-detect: affected < 1.4.1; fixed in 1.4.1

## Suggested inspection (read-only)
- Maven com.synopsys.integration:synopsys-detect: check the installed version with your package manager.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on com.synopsys.integration:synopsys-detect.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-6w3h-vq7m-v3qf (GitHub-reviewed advisory GHSA-6w3h-vq7m-v3qf lists affected ranges: Maven com.synopsys.integration:synopsys-detect >=0 <1.4.1)

Commands are suggestions: review each one before running it.

Loading voting…