Bouncy Castle has a flaw in the Low-level interface to RSA key pair generator
CVE-2018-1000180GHSA-xqj7-j8j5-f2xr
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (org.bouncycastle:bcprov-jdk14 1.60; org.bouncycastle:bcprov-jdk15 1.60; org.bouncycastle:bcprov-jdk15on 1.60), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
Maven org.bouncycastle:bcprov-jdk14
- Affected
- < 1.60
- Fixed in
- 1.60
Maven org.bouncycastle:bcprov-jdk15
- Affected
- < 1.60
- Fixed in
- 1.60
Maven org.bouncycastle:bcprov-jdk15on
- Affected
- < 1.60
- Fixed in
- 1.60
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-xqj7-j8j5-f2xr lists affected ranges: Maven org.bouncycastle:bcprov-jdk14 >=0 =0 =0 <1.60
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 7.5 · CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N
- EPSS
- CVE-2018-1000180: 3.42% estimated exploitation activity in the next 30 days; percentile 88.92 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Bouncy Castle BC 1.54 - 1.59, BC-FJA 1.0.0, BC-FJA 1.0.1 and earlier have a flaw in the Low-level interface to RSA key pair generator, specifically RSA Key Pairs generated in low-level API with added certainty may have less M-R tests than expected. This appears to be fixed in versions BC 1.60 beta 4 and later, BC-FJA 1.0.2 and later.
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 1 · created ·
Published from ghsa record GHSA-xqj7-j8j5-f2xr
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2018-1000180 Advisory: Bouncy Castle has a flaw in the Low-level interface to RSA key pair generator IDs: CVE-2018-1000180, GHSA-xqj7-j8j5-f2xr Record: https://patchnext.com/advisories/cve-2018-1000180 (revision 1, source checked 26 Oct 2026, 16:40 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: High (CVSS 7.5) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: org.bouncycastle:bcprov-jdk14 1.60; org.bouncycastle:bcprov-jdk15 1.60; org.bouncycastle:bcprov-jdk15on 1.60. A vendor fix does not mean a deployment is fixed. ## Affected components - Maven org.bouncycastle:bcprov-jdk14: affected < 1.60; fixed in 1.60 - Maven org.bouncycastle:bcprov-jdk15: affected < 1.60; fixed in 1.60 - Maven org.bouncycastle:bcprov-jdk15on: affected < 1.60; fixed in 1.60 ## Suggested inspection (read-only) - Maven org.bouncycastle:bcprov-jdk14: check the installed version with your package manager. - Maven org.bouncycastle:bcprov-jdk15: check the installed version with your package manager. - Maven org.bouncycastle:bcprov-jdk15on: check the installed version with your package manager. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on org.bouncycastle:bcprov-jdk14, org.bouncycastle:bcprov-jdk15, org.bouncycastle:bcprov-jdk15on. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-xqj7-j8j5-f2xr (GitHub-reviewed advisory GHSA-xqj7-j8j5-f2xr lists affected ranges: Maven org.bouncycastle:bcprov-jdk14 >=0 =0 =0 <1.60) Commands are suggestions: review each one before running it.
Loading voting…