Skip to content

← Actionable
High, CVSS 8.6amended

OISF suricata-update unsafely deserializes YAML data

CVE-2018-1000167GHSA-7c4h-w765-6pwg

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (suricata-update 1.0.0b1), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS 4.0
8.6 · CVSS:4.0/AV:L/AC:L/AT:N/PR:N/UI:N/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N · score source
EPSS
  • CVE-2018-1000167: 4.05% estimated exploitation activity in the next 30 days; percentile 90.66 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Suricata-Update uses the insecure yaml.load() function. Code will be executed if the yaml-file contains lines like: The vulnerable function can be triggered by "suricata-update list-sources". The locally stored index.yaml will be loaded in this function and the malicious code gets executed.

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 3 · amended ·

    Amended from ghsa record GHSA-7c4h-w765-6pwg

  2. Revision 2 · amended ·

    Reviewed OSV alias/range/CVSS4 correction; package source scopes and original publication preserved. No customer finding resolved.

  3. Revision 1 · created ·

    Published from osv record GHSA-7c4h-w765-6pwg

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2018-1000167

Advisory: OISF suricata-update unsafely deserializes YAML data
IDs: CVE-2018-1000167, GHSA-7c4h-w765-6pwg
Record: https://patchnext.com/advisories/cve-2018-1000167 (revision 3, source checked 26 Oct 2026, 13:25 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: High (CVSS 8.6)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: suricata-update 1.0.0b1. A vendor fix does not mean a deployment is fixed.

## Affected components
- PyPI suricata-update: affected <= 1.0.0a1; fixed in 1.0.0b1

## Suggested inspection (read-only)
- `python -m pip show suricata-update`: prints the installed version. Run with the environment that serves production active.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on suricata-update.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/GHSA-7c4h-w765-6pwg (OSV record GHSA-7c4h-w765-6pwg lists affected ranges: PyPI suricata-update >=0 <1.0.0b1 (fixed))
- Verified: https://github.com/advisories/GHSA-7c4h-w765-6pwg (GitHub-reviewed advisory GHSA-7c4h-w765-6pwg lists affected ranges: PyPI suricata-update >=0 <=1.0.0a1)

Commands are suggestions: review each one before running it.

Loading voting…