LightSAML Incorrect Access Control vulnerability
CVE-2018-1000165GHSA-vg4f-8v9q-5c3x
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (lightsaml/lightsaml 1.3.5), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
Packagist lightsaml/lightsaml
- Affected
- < 1.3.5
- Fixed in
- 1.3.5
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-vg4f-8v9q-5c3x lists affected ranges: Packagist lightsaml/lightsaml >=0 <1.3.5
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 7.5 · CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:H/A:N
- EPSS
- CVE-2018-1000165: 1.22% estimated exploitation activity in the next 30 days; percentile 68.83 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
LightSAML version prior to 1.3.5 contains a Incorrect Access Control vulnerability in signature validation in readers in src/LightSaml/Model/XmlDSig/ that can result in impersonation of any user from Identity Provider. This vulnerability appears to have been fixed in 1.3.5 and later.
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 1 · created ·
Published from ghsa record GHSA-vg4f-8v9q-5c3x
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2018-1000165 Advisory: LightSAML Incorrect Access Control vulnerability IDs: CVE-2018-1000165, GHSA-vg4f-8v9q-5c3x Record: https://patchnext.com/advisories/cve-2018-1000165 (revision 1, source checked 26 Oct 2026, 14:19 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: High (CVSS 7.5) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: lightsaml/lightsaml 1.3.5. A vendor fix does not mean a deployment is fixed. ## Affected components - Packagist lightsaml/lightsaml: affected < 1.3.5; fixed in 1.3.5 ## Suggested inspection (read-only) - Packagist lightsaml/lightsaml: check the installed version with your package manager. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on lightsaml/lightsaml. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-vg4f-8v9q-5c3x (GitHub-reviewed advisory GHSA-vg4f-8v9q-5c3x lists affected ranges: Packagist lightsaml/lightsaml >=0 <1.3.5) Commands are suggestions: review each one before running it.
Loading voting…